Return to Level1Techs.com

Lenovo ThinkPad E585 - Ryzen 2500U/Vega 8 - Review, Impressions, Linux, etc


#22

Thanks for your reply, but i used 4.17 (from Devuan testing) and I just compiled 4.18.5. Tried today with evtest and it doesn’t detect that keypresses. I have to investigate about that…


#23

If it works for most people I have to test and look for differences with a Ubuntu Live-USB :slight_smile:


#24

Got to honestly say, after seeing what Acer did in advertising upgradability in the Aspire 3 Ryzen 7 2700U unit, and them NOT EVEN INCLUDING THE SATA HDD CABLE:

https://images-na.ssl-images-amazon.com/images/I/71WNM2rTbxL.jpg

For which to add the cable you’d be voiding the warranty ANYWAYS, so they can’t sell you a 2.5’’ HDD upgrade kit…

I’m thinking this is my next laptop in the 2700U config. Planning to run 4.19 Kernel with Cinnamon DE and Ubuntu 18.04.1.

Also, thank you very much for the teardown and letting us know it’s Phillips screw heads, not pentalobe or anything insane.

Have you tried gaming with the performance CPU Governor and with C-states off in the kernel boot command line? That’s how I’m likely to run this system. My previous system was a Thinkpad X200T with GMA 4500 graphics that couldn’t even run L4D2 past 15fps on low everything.


#25

If only I knew about this before I force updated Mesa on my machine and completely broke it. I can’t recover my Thinkpad X200T 16.04.5 install now. Libc is beyond broken.


#26

Have you tried gaming with the performance CPU Governor and with C-states off in the kernel boot command line? That’s how I’m likely to run this system. My previous system was a Thinkpad X200T with GMA 4500 graphics that couldn’t even run L4D2 past 15fps on low everything.

You mean like Feral’s Gamemode tool? I have not tried that, but I need to


#27

It’s actually easier than that:


#28

Oddly enough that link has been clicked enough times to get new achievement, so I did recheck whats going on, and its still the cheapest one

What weirds me is that E485 because its older, +10 copper coins, and its 14 inches instead of that 15.6 inches :man_shrugging:t2:


#29

Hi

I have just purchased a Lenovo E585. Many thanks to the forum member ‘beer’ for the review and tips on disassembly. Reasonably pleased with the laptop except for the screen which has noticeable backlight bleed (I would have thought this would be a thing of the past nowadays).

I have a Crucial M4 SSD which I have installed into the spare SSD slot. My initial problem was that it is a 9.5mm SSD and would not fit into the laptop. I had to remove the SSD spacer to convert it to 7mm, I also had to cut the SSD screws. When installing the SSD I followed the instructions as given in the E580 and E585 Hardware Maintenance Manual.

Unfortunately, since installing the SSD the computer takes ages to POST or get to the BIOS screen. Windows 10 on the pre-existing NVMe now gets stuck when trying to boot, maybe if I left it long enough it would eventually boot. I’ve disabled Secure Boot in the BIOS. I cannot seem to find any mention of the Crucial SSD in the BIOS and it is not listed on the BIOS diagnostics boot screen when POSTing.

Maybe this SSD is not compatible with the E585? Any ideas would be appreciated. Thank you.


#30

Always firmware update Crucial SSDs before first use. They had a really bad firmware issue with the MX500 I think a while back.


#31

Thanks for the suggestion I’ve used the SSD previously on another computer. It has Kubuntu 18.04 installed on it.

I’m currently trying to create a bootable bios flash usb memory key to update the laptop bios. The instructions in the download say to run ‘mkusbkey.bat’ but this file does not exist!

The current bios is ROUET44W 1.24 2018-06-18

Trying to update to 1.32

Should have updated the bios before installing the SSD :frowning:


#32

Success! Mostly.

I managed to get WIndows to boot somehow by pressing the power button. Have flashed to 1.32 bios and now drive is recognised correctly.

I can get Linux to the grub (?) screen but it doesn’t boot. Probably a UEFI issue or kernel issue.


#33

I saw the Reddit post also with the panel upgrade the guy mentioned. I couldn’t find it either. I did however find Boe nv156fhm-n61. Could that be the correct upgrade you think? I just ordered this laptop as well and would love a better screen than the stock one!


#34

Not really sure, I haven’t looked much into it personally. It’s the same panel as the E580, so the upgrade should be the same if you want go search around and see what others have used.

To be honest though, I’m actually pretty happy with the display. Despite not having the greatest color accuracy, it still looks nice. It’s not something I’ve had an issue with other than the low max brightness, and I’m pretty anal about having nice displays.

The one upgrade I DO want to try, though, is the backlit keyboard. I always struggle to read the keyboard on this thing at night.

Not that you asked (just adding more info to the thread I guess), but Lenovo lists 3 compatible part numbers for the backlit keyboard:

The only difference between these 3 is the manufacturer. Everything I’ve read points to Lite-On part (01YP680) being the best quality, and Chicony being the worst.

CHY = Chicony
LTN = Lite-On
PMX = Primax


#35

The laptop has gone back to to way it was behaving before :slight_smile: Slow POST and hanging on booting Windows.

I have also been unable to boot Kubuntu from USB stick. Will check out the link in the first post.

EDIT: Yup ivrs_ioapic[32]=00:14.0 on command line does the trick for booting from USB :slight_smile:

Will try with SSD next. - Nope SSD no longer recognised in BIOS :frowning:


#36

Mine is running perfectly fine now in linux (on SSD) with kernel 4.19, aside from bluetooth. Try turning off some of the security features in the bios, and see if that helps. I have most of the security features turned off. Turn them all off, and if that works you can toggle them individually to see which one is causing it.


#37

It’s most certainly a SSD incompatibility issue. I recommend trying a Samsung 860 EVO just to be sure it’s not your unit that has the issue.


#38

Tried turning off the security features, did not help. But thanks for the suggestion.

I’m really disappointed that my SSD doesn’t work with the laptop. There is nothing wrong with it and I wanted to reuse it. Trying to avoid spending more money.

EDIT: Samsumg 860 EVO definitely works in the E585 ?


#39

Just got my E585 two days ago. Does anyone else have a weird feeling about their displays? Like, I feel that it does have 60hz - it just feels blurry during movement?


#40

Yes, mine is a bit blurry too. The screen does not seem fantastic. I will check to see if it is like it in Linux.

I don’t have another SSD at hand to test. There is a SanDisk SSD in my Mother’s computer but I do not wish to mess around with that. I tried a 2.5" Western Digital SATA HDD and that works fine in the E585 .

I think the chassis of the E580 / E585 is quite cheap and badly constructed. I broke one of the little plastic tabs off when removing the back. I also snapped off a slither of plastic located above the power port and below the plane of the keyboard. The back panel snags on something near the power port. I think my old Lenovo B570 is better constructed and easier to service to be honest.

I take it back about being pleased about the laptop except for the screen. The aluminium cover just gives the impression it is well made, when in reality it is not. Like most consumer electronics nowadays it is designed to break and not endure.

Sorry to be such a moaning minnie.

Thanks for the help guys :slight_smile:


#41

Sorry to hear your experience has been negative so far. Compared to the laptop I was coming from, this thing has been holding up quite well. I might also use Linux to see if my overall experience is any different with the battery life, though I’m already predicting that it’ll be alot better.