Lenovo new touchpad issues

I own a Lenovo W540 with Windows 10 on it and the default touchpad is absolutley terrible. I saw that it was possible to install a new touchpad from the W541 onto the W540. The new ones are much better, so I proceded to do that. This one to be exact. http://www.ebay.com/itm/272000239170?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

So i succesfully installed the new touchpad on my W540 within 5 minutes, and everything was working fine it seemed. I then tried to go into the mouse settings in control panel to adjust things, and there was no thinkpad tab for changing advanced mouse settings. I then uninstalled the ultranav drivers and reinstalled the newest ones, they installed without error. That didnt work. I tried near everything in the book to fix it. After hours of work and countless restarts I decided to do a new fresh install of Windows 10 and install the drivers. Surely that would work. Nope. Still no thinkpad tab in the mouse settings. Still no way to customise my new touchpad. Iv’e also tried putting this touchpad on a Windows 7 W540, and it doesnt work their either. So its not a Windows issue and is definetly some sort of issue with the touchpad.

Anyone know what is causing this massive headache? I just want gestures and 2 finger scrolling and such. I am a technically competent user and can not figure this out.
Any help is super appreciated.


It could be trying to download drivers for the touchpad related to your exact model of laptop. Have you tried installing a generic Synaptics driver?

Yes I'll go into more specifics of what I have tried. So I've tried the newist generic synaptic driver. Ive tried many different versions of lenovo's drivers. Like a lot and multiple times for each.. Anyways the best current guess for what the problem might be I think is that the driver software might for some reason check to see if the machine I have is supposed to have the touchpad I have. From device manager I found that the hardware id of the tochpad is *LEN0034 which after a google search I found that this device is assosiated with the T540p. And I have a W540. Although it fits in fine and plugs in fine and should work fully fine and I see no reason why it shouldnt. Anyways I downloaded the newest touchpad drivers for the T540p, but as I suspected they are the exact same drivers offered for the W540 and W541.

One thing I tried doing was changing the hardware id of my W540 to match the id of a W541, but that resulted in 0 change.

Every once in a while when i try to open mouse settings it will pop up with an error message saying the synaptics driver is not installed or that a synaptics device is not detected. In device manager the device is listed as Synaptics Pointing Device though, as it should be. The only thing that doesnt work with my touchpad is opening the advanced settings. Also Ive tried just navigating to and running the executable that in the Synaptics Program Files folder. But it just does nothing.

I was thinking maybe if there was some way to change the hardware id of the new touchpad to match that of one for the W541. But it seems dumb that those need to match so I'm not too optimistic about it.


Closed due to spam and necro.