Return to Level1Techs.com

Lenovo E595 Ryzen 3700U Review and Linux

#1

So as a fresh high school graduate going to college for a computer science program very soon, I like many others thought that now would be a very good time to purchase a laptop. My requirements aren’t too heavy. Since I want to run Linux and also run a windows vm in case the school needs me to run any windows only programs, I would need something with at least 2 cores. Fortunately both Intel and AMD have quad cores available in many laptops. I don’t play much games but it would nice for my laptop to be able to run some light games. Since I am running linux, I need something with decent integrated graphics as switchable graphics is not supported well under linux which means a laptop with a ryzen apu would be best.

I decided to purchase an Lenovo E595 since Lenovo had just released this new model with the new refreshed Ryzen 3000 APUs. I bought the laptop with only the top APU and 1080p IPS display and cheaped out on everything else since I could save a few hundreds of dollars by upgrading the other parts myself and more with a coupon. I will refer to the out of box configuration as the ‘stock’ configuration and the configuration with the added parts as the ‘upgraded’ configuration. Also I must thank r/sacabonos from reddit for the tip to fix nvme more on that latter.

TL;DR This is an amazing laptop. Much better than my old one. Lenovo fixed the Linux issues from the previous E4/585 but Linux setup needs kernel parameter to work with my nvme ssd. WiFi and BT just works. Also make sure you use dual channel RAM.

‘Stock’ configuration as purchased:

APU: AMD Ryzen 3700U with Vega 10 Mobile graphics

RAM: 1x4GB Samsung 2666 cl17

Storage: 1TB 5400RPM Hard Drive

Display: 1080P IPS 250 Nits

‘Upgraded’ configuration:

RAM: 2x8GB HyperX impact 2400 cl14

Storage: 1TB Adata SX8200 pro.

Subtotal was about $800 but I used the coupon THINKPADSAV20 which saves me 20% so my total without tax was around ~$650. An awesome deal! Along with it I bought an Adata SX8200 pro 1tb ssd and 16GB of the best ram for this laptop, HyperX Impact 2400 cl14. In total I have spent around $900.

The build quality of this laptop is very good. The IPS display is totally worth the small extra cost though free-sync would be highly desired. It is clear and have very good viewing angles. The laptop is made with aluminum for the screen and plastic everywhere else. There is little flex on the keyboard and the buttons feel nice to type on.

There are a few things that I dislike about the E595. The battery wasn’t improved from the last generation’s 45 watt hour so it still only lasts around 4-5 hours. Luckily the charger is small enough though to carry around. Another problem is that the area where your right palm rests on can get hot.

I ran some benchmarks and tests in Windows in the ‘stock’ configuration and in the ‘upgraded’ configuration.

Opening up the laptop is not very difficult. There are 9 small phillips head screws that are non-detachable from the plastic back so just loosen them and start to pry open the tabs holding the cover.

Here are some photos.

As you can see the internals are exactly the same as the previous E585.

I replaced the stock thermal paste with Thermal Grizzly Kryonaut which is one of the best non-conductive pastes. When testing the temps under full CPU load the max temp was 83 degrees Celsius and 81.5 degrees Celsius with Kryonaut. With only a one and a half difference the stock paste Lenovo uses is pretty good.

Now for the benchmarks. I used Cinebench r15 and Unigine Superposition.

‘Stock’ Scores:

Cinebench:

OpenGL: 31.98 fps

CPU single: 144cb

CPU multi: 633cb

Superposition (1080P Medium): Freezes when loading with only 4gb of ram.

‘Upgraded’ Scores:

Cinebench:

OpenGL: 46.18 fps

CPU single: 145cb

CPU multi: 705cb

Superposition (1080P Medium): 1202

Enough with the windows benchmarks. I know most people are interested, myself included, in how this laptop runs Linux. So lets break open the window and toss in the penguin. :wink:

The previous E585 had BIOS problems that made running Linux more difficult but not impossible. I have good news and bad news. The good news is that Lenovo fixed that problem in this model and most likely in the E/T485 as well. The bad news was that I encountered other minor obstacles. The first one was that on booting Manjaro 18.04 caused the laptop to be stuck on loading ‘TLP system startup/shutdown’. I’m not sure if this also effects other Linux distros but the problem was fixed in newer kernels so I downloaded the release candidate for 18.1 and it booted successfully.

The next problem was when I was selecting which drive to install to. Manjaro failed to detect my Adata sx8200 pro nvme ssd. Luckily, r/sacabonos said that the solution to fix this issue was to add this to the kernel parameters: ‘nvme_core.default_ps_max_latency_us=5500’

To add this, once the laptop boots into grub you need to press ‘e’ with the Linux OS to boot selected and add ‘nvme_core.default_ps_max_latency_us=5500’ to the end of the line that starts with ‘Linux’. You only need to do this twice, once for installation and the first boot after, then you can add the parameter mentioned above to the grub configuration in the ‘GRUB_CMDLINE_LINUX_DEFAULT=’ line then run sudo update-grub so you don’t have to worry about this problem again.

After these small issues, Linux is running well. The built in WiFi and Bluetooth works when running Manjaro 18.1-rc1 and Kubuntu 19.04. The only other small issue is that the track-pad doesn’t feel smooth and accurate like in windows. If anyone could provide suggestions on getting the track-pad to behave windows like please comment.

Overall am glad I made the decision to purchase this laptop. I believe it will serve me well in college and after.

11 Likes

Ryzen 3000, Booting Linux, and You
14" laptop recommendation
#2

Here are more pics since the fourm won’t let me post more than 2 images:


6 Likes

#3

Thanks for the awesome review!

I’ve bumped your user up to member to remove the image limits.

This is some good info and it’s actually making me want to get one.

3 Likes

#4

Yea I wish they offered a model where they remove the second hard drive area and fill it with battery. 3-4 hours more battery life around same price now that is what I am talking about. Is this the one where it can charge up to 80% battery in like 30-45 minutes?

0 Likes

#5

Good to know it needs less kernel arguments to get working. I personally will be loading Fedora KDE to get a relatively new kernel + relatively new Mesa to see how it games. Personally interested in how well Hat in Time would play.

And this also confirms the DIMMs are not soldered!

I am curious though if the USB-C port can take in those Macbook (ultra slim) USB-C charger banks, like this Anker one:

0 Likes

#6

Thanks for sharing! I’m in the market for a new laptop and this one has been on my shortlist for a while. The Linux compatibility in particular has been holding me back.

Do you know what Wifi card this has? I presume you bought this in the US, but here in the UK this model comes with a “REALTEK Wireless 8822BE 2x2 AC, Bluetooth Version 4.2” card. I have seen various forum posts across the internet of users needing to swap this out for an Intel wifi card for better Linux compatibility. In some regions the laptop apparently ships from Lenovo with an Intel card.

0 Likes

#7

Install synaptics touchpad driver instead of the default libreinput (or the name’s something like that, I don’t remember). The synaptics is EOL but works well, while the FOSS doesn’t work so well as you’ve said.

0 Likes

#8

Good to hear it’s relatively painless to get linux working on this newer laptop. Hopefully in future kernel releases on Manjaro it’ll include the NVMe line as well

0 Likes

#9

libinput

1 Like

#10

My XPS 15 will charge off one of those, I don’t see why this won’t.

0 Likes

#11

I went and looked at a E580 and the voltage requirements are 20V at ~1A over the USB-C port.

0 Likes

#12

Interesting. :frowning:

0 Likes

#13

It must support USB PD with 20V support in order to work.

0 Likes

#14

Hey OP,

I have a t495s, same CPU as you. Can’t seem to install 18.1 rc2 (kde or xfce) or 19.05.21 (xfce only available at the moment).

Which version did you install? I assume RC2 but none seem to work for me. While 19.05.21 actually installed, it doesn’t boot up at all. I also tried it with your command after pressing e in grub and it still does not boot.

18.1 just errors out and doesn’t finish the install.

0 Likes

#15

Not OP, but if you give more info, I’d be happy to try to help you. What errors are you seeing when it errors.

What GPU configuration do you have?

18.1 just errors out and doesn’t finish the install

That’s unlikely a problem with the laptop and more likely a problem with manjaro itself

it doesn’t boot up at all

Does it give a boot error or just give you a black screen?

0 Likes

#16

How about the e495, is there anyone using Linux with it, has it improved too?
I was looking to get either this one, which seems to be a bit smaller than other regular 15" laptops or the e495 (14", a bit smaller and perfect for going to the campus with it inside a small backpack)

0 Likes

#17

Sorry that I haven’t responded sooner!

Here is a picture of the error code I get when trying to install 18.1rc2.

…and God Damn It. I just tried to install rc1 like OP did and while it does hover at around 28-30% like it did with rc2, it eventually finishes and installs normally whereas rc2 does not.
For what it’s worth, Kubuntu 19 also installed no problem.

“Why bother trying rc1 when rc2 doesn’t boot?” -Last Words

So if anyone has a similar problem, try rc1 and see if it works over rc2.

I do have a question though: given that rc1 is now installed and running, will this be upgraded to the final version of 18.1 when it comes out?
Or will I have to install the final product overtop given that what I have now is a release candidate?

1 Like

#18

I would imagine so.

0 Likes

#19

I have the E585 , fantastic machine.

Its nice to see they upgraded the wifi card , the stock one in the E585 at least in Europe is crap. Not a huge problem good 2x2 cards on amazon are cheap.

I agree they should offer an extended battery option in place of HDD.

Is there a guide to fudge the bios on the E585 to get it running linux ?

0 Likes

#20

It is nice to see that M.2. 2280 SSD work on this laptop since the lenovo psref only mention the M.2 2242 SSD.

0 Likes