Latest 13.9 AMD Catalyst Control Center

Hi All, 

When BF4 launched, it prompted me to download the new 13.9 AMD Catatyst Control Center. After downloading it and upgrading it from 13.8, it doesn't seem to be able to update itself. I tried many times but it still stuck at 13.8

I've tried uninstalling the Catalyst but still the same results. 

I use a Gigabyte Radeon HD 7850. 

Can anyone please help? Thanks!!


*Sorry for my english, if I have any mistakes* 



You might try one of the new betas .

I'm scared its not stable because it is still in beta.

I have the same problem, AMD Catalyst is a piece of crap that only works when you least expect it to.

I am pretty sure that the problem that you are having is that you didn't uninstall your old drivers before trying to install the new ones. There is an AMD cleanup utility that I use before installing a new driver. I got it off of their website, but can't seem to find a link to it. Anyway, I am running the 13.11 beta drivers and am having no problems (aside from not having enough vram for BF4 as I only have 1gb).

Did you just download the new installer and run it? It should run the set-up and install everything itself. Mine always does.

And the latest beta 13.11, is great. Especially with crossfire.

I've tried updating to the latest beta driver but it gives me an error when i try to update it. Saying something about contacting them to give permission. I've no clue on what to do.

Try doing that and then reinstalling the latest drivers/beta drivers. REMEMBER to make a system restore point before doing this just as a precaution. Also I'm running Beta drivers right now. They've improved the performance of a lot of games for me, no crashes what so ever. I think the unstable notice is just a disclaimer.