Return to Level1Techs.com

Laptop Performance

linux
arch
laptop
#1

my laptop takes very long to boot almost 50 something seconds. i want to know if i can improve my boot time. and i also want to know how to set my laptop to full performance mode like in windows u can set to battery saver or high performance.

systemd-analyze

systemd-analyze blame


systemd-analyze critical-chain

2 Likes

#2

You can download a CLI app named cpupower and you can change the performance governor to performance.

PS: I love how you themed KDE. It looks like Mac OS which is :love_hotel:

0 Likes

#3

thank, i actually didn’t wanted it to look like mac but i like the layout nd all so i let it be :smiley:
and i install cpupower and set it to performance thats it? and what about the boot time, can i improve my boot time.

1 Like

#4

Yes. Just insert this command into the terminal:

cpupower frequency-set -g performance

This will not survive reboots tho, so you would have to enter this every time you reboot.

To have it set to performance and survive reboots, create a copy of and edit the file named cpupower under /etc/default/. There may be different lines named governor=(text) in the file. Something along the lines of:

governor=performance
governor=powersave
governor=userspace
governor=ondemand
governor=schedutil

Put a # in front of all of them but governor=performance. So it would look something like this:

governor=performance
#governor=powersave
#governor=userspace
#governor=ondemand
#governor=schedutil

What the # does is it tells the software to ignore that line. So it would only look at the line that says performance. If the file doesn’t contain the governor=performance line. Add it.

Then after editing that file, save it, and run the command systemctl enable cpupower and you should be good to go.


As far as tuning systemd to improve boot time, I am of no help. I have never tuned my boot time before. It does look as if you can stop the lvm service from running and that will save you like 10 seconds on your boot time. I don’t know if you need lvm tho. And I know nothing about lvm, so I don’t wanna break your system. :slight_smile:

Going from the Mint forums ( https://forums.linuxmint.com/viewtopic.php?t=282437 ), the NetworkManager-wait-online.service is a service that “waits for NetworkManager to report an active connection (or for a 30 second timeout to expire); for the system “to be online”. This is so as to guarantee that the remainder of the startup sequence finds itself capable of communicating over the network; with, say, the NFS server with your home directory, or…” Basically, it just is there to make sure that there is an active connection to the network. It can also be stopped from running on boot with the command sudo systemctl mask NetworkManager-wait-online.service and that should save you about 8 seconds.

2 Likes

#5

I hospital what you did here.

Summary

Perhaps you might edit once more?

I would start by making a copy of existing fil, cp cpupower cpupower.backup
so it can be restored?
Might the file need to be edited as root / elevated privelidges at all? might be worth mentioning?

Otherwise

, much hospitals

2 Likes

#6

I too do not have experience with such things. I just wanted to show you it could be worse, I don’t think I would have any way of speeding up Firmware slowdowns =(

The only thing I could think of for your issue though is a leaner DE or a WM to get it much faster

1 Like

#7

Check your Motherboard options, I would imagine that’s why your firmware is high.

That time is still nice tho.

1 Like

#8

Thanks! I also just noticed that the second highest time on there was the drive where root is. maybe upgrade the storage (for OP)

Edit: it looks like it might be spinning rust so I’d definitely get an SSD

0 Likes

#9

ok thanx, and is there a way to verify that it is indeed set to performance after rebooting? and i don’t use lvm how can i stop that service on boot?

0 Likes

#10

yes, actually before KDE i had GNOME installed and the GDM loaded much faster than SDDM. its just GNOME as a DE is kinda laggy, so i switched to KDE as it was a much smoother experience, its just SDDM takes longer to load. also plymouth transition to GDM was also smoother than SDDM.

0 Likes