L1KVM Main display not recognized by macOS when waking up from sleep

I recently setup my dual monitor 1.4 Display Port KVM, what an awesome device! After my vacation I’ve noticed one issue with it when using my work laptop via a Thunderbolt dock connected to the KVM. Here’s a rundown of my setup:

Displays:

ROG PG279Q @ 1440p (“main” display)
Dell U2412M @ 1920x1200

Both displays are connected to the console ports of the KVM with two meter long Club3D 1.4 DP cables. PC1 is connected to my gaming PC with one meter long Club3D 1.4 DP cables. PC2 is connected to my CalDigit TS3+ Thunderbolt dock, one monitor with a one meter long Club3D 1.4 DP cable, the other with a 1.8m Club3D 1.4 DP to USB-C cable. The dock only has one DisplayPort connector on it, plus the DP to USB-C cable should be used by the Dell monitor anyway. Dock is connected to a 2018 Macbook Pro via the thunderbolt cable provided with the dock.

On my Windows gaming machine, everything seems to work fine. I can get the ROG display up to 144Hz no problem and I haven’t encountered any issues. On the Thunderbolt dock connected Macbook I’ve noticed that when I wake the machine up from sleep, both monitors will turn on, but the ASUS monitor will eventually just say “DISPLAYPORT NOT CONNECTED” or something to that effect, and go back to sleep. Checking out macOS display settings, it doesn’t show the main display at all, only showing the MBP display and the Dell monitor.

There’s two ways I’ve found to fix this issue. One is to reboot the MBP and the other is to remove the thunderbolt cable and plug it back in. Reboot seems to work always, but it’s time consuming and annoying. Plugging the thunderbolt cable back in seems to work like 50% to 75% of the time, not quite sure what’s going on there.

I’ve also tried switching the KVM inputs from the gaming machine back to the thunderbolt dock, but that doesn’t affect the situation at all. Waking up the Windows gaming machine by switching the KVM input to it does turn on the main display however, so it’s clearly something to do with the dock part of the equation. Searching the forums, I found the topic “DP 1.4 KVM with Thunderbolt Docks” (can’t post a direct link) which seems to have some of the same hardware, though not exactly the same issue I’m having. Could it be the Thunderbolt cable in this case too? I just find it a bit confusing that it works fine before the machine goes to sleep, and stops working every time I wake it up from sleep. I don’t have alternative thunderbolt cables (yet), so I haven’t tested with another.

I had same problem, DisplayPort to USB-C cable does not work well, i changed mine to CalDigit usb-c pro dock which has two DisplayPorts and now everything works as intended, I have posted my troubles and solutions here 1.4 DP L1KVM switch DIY remote - #23 by tadas

Edit: i think i read somewhere that you need powered Display port to usb-c cable, but i didn’t have one and didn’t want to prolong my pain using l1kvm switch if that cable would not work.

Hmm, guess I should check my cables, but I’m pretty sure that the DP - USB-C cable is used by the Dell display, which does turn on when I wake up from sleep

Maybe you should try disconnecting DisplayPort → usbc cable and see if it will work with one monitor, somehow i think that the problem will disappear. Event if now the monitor works but “docked” monitor doesn’t, i still think its the dp->usbc cables fault.

I tried it without the DisplayPort - USB-C cable connected to the KVM. Like I thought, that was the cable for the Dell monitor, so obviously that didn’t work anymore. But the same problem persists with the ASUS monitor. When I wake up the laptop from sleep, it’ll wake up the monitor, but after a while it’ll display the message “DISPLAYPORT NOT CONNECTED” and go back to sleep again.

Removing and plugging the Thunderbolt cable back in fixes this. Fiddling with the Displayport connectors on the KVM, the display or the Thunderbolt dock doesn’t seem to change anything, once the Macbook Pro thinks that the display doesn’t exist, only a reboot or re-plugging the TB cable will make the display appear again in macOS display settings

Since you already went the extra mile, does it display the same behaviour with your other monitor? I mean, if you switch monitors, what happens?

I’m not sure if this is exactly what you meant, but I tried swapping the console ports on the KVM, so now the ASUS monitor should be going through the DP - USB-C cable and the Dell one is going through just Displayport cable (total run three meters). And it’s still the same. Both monitors wake up but ASUS monitor just says that displayport isn’t connected and goes back to sleep.

I actually noticed that when you plug the Thunderbolt cable back in to fix this, you need to time it for it to work. If I try and remove the cable and plug it back in once the ASUS monitor has gone back to sleep again, the cycle just repeats. But if I remove the cable and plug it back in while the ASUS monitor is showing the “cable not plugged in” error, macOS notices the display and I can use it. Well, I’ve been able to replicate this once, need to test a few more times to be sure. But like I said in my initial post, removing and plugging the Thunderbolt cable back in doesn’t always work, maybe that timing explains it.

EDIT: Well, maybe it’s not timing related and just random? Anyway, a lot of the time disconnecting and connecting the TB cable works, but sometimes it doesn’t

you might try a moshi bi-directional usbc to dp cable and see how that goes?

Do you think that would help in this case? Like I mentioned earlier, I’ve tried removing the whole DP - USB-C cable from the equation, so just having the ASUS monitor connected to the TB dock, and the behavior still persists. The cable run in that case would be like this:

Dell and ASUS monitor connected to console ports of KVM with 2m Club3D DP cables
PC1 connected to my gaming PC with two 1m Club3D DP cables
PC2 connected to CalDigit TS3 Plus with one 1m Club3D DP cable (so just monitor 1, ASUS monitor in this case, connected)
Macbook Pro connected to CalDigit TS3 Plus with the included Thunderbolt cable. Not sure how long this is, but I think it’s about 0,5m, less than 1 meter at least.

I’m happy to try other cables, I’m just not sure if another USB-C - DP cable would help, if the problem persists even when that cable isn’t connected

I bought a Moshi USB-C to DisplayPort cable just to verify, but I am still experiencing the same issue. Since the ASUS display is connected with DisplayPort cables the whole way through, I figured this would be the case, but wanted to verify. Besides testing another TB cable, I don’t think there’s much else I can change in this setup.

I’ll probably upgrade to the CalDigit TS4 at some point, guess I’ll try and report back if that ends up changing anything