KVM GPU Passthough - AMD 480 GPU error 43


A while ago I borrowed an MSI AMD 8gb 480 from a friend and got this to pass-through to a windows guest. As this worked without issue i brought an ASUS 4GB 480 in order to pass-though to a windows guest. Seeing as the 8gb 480 passed through and worked in a windows guest i thought it’d be simple to get the 4gb 480 to work on a windows guest. Apparently not.

When i set up the 4gb 480 i can pass this through to a windows guest, it shows up in device manager but there’s not output to the screen. Device manager shows error 43 and i can pass-though to Linux guests without issue. I know this is an issue with nvidia cards but seeing as this is an AMD card i don’t know what’s causing the issue. I’ve done some searching but can’t see any solution to this.

I’ve rebuilt the guest, tried both seabios and OVMF , i440fx and Q35. The same issue on all of these configurations. Tried both the latest drivers and older drivers. I’ve also rebuilt the host from a Ubuntu server 16.04 host to a Fedora 27 server host and again the same issue.

Does anyone have any ideas on how i can resolve this issue?


Wasn’t error 43 a nvidia specific error when it detects it’s in a VM?

edit: nvm, skipped that line

So after rebuilding everything the solution couldn’t have been simpler. Flashed the BIOS on the card and pass-through is now working on windows. Wish i’d tried that to start with.