[Kubuntu] Steam missing libc.so.6 library

Hi, I'm relatively new to linux. I started with Kubuntu 15.04 about 10 months ago when Tek Syndicate inspired me to give linux a go. I'm currently running Kubuntu 16.04, and using linux has certainly being quite a learning experience.

I'm having a bit of a problem with steam for linux as of late. It started after a fairly major plasma crash which I had no choice but to press the system reset button. However I'm not convinced that is the cause of the problem since I recall before the crash steam was bugging me about an update. When I launch steam from the terminal it gives the following output:

Running Steam on ubuntu 16.04 64-bit
STEAM_RUNTIME is enabled automatically
Error: You are missing the following 32-bit libraries, and Steam may not run:
Error: Couldn't find bootstrap, it's not safe to reset Steam. Please contact technical support.

It seems strange to me that after serving me faithfully for about 10 months, steam would need me to install a new library as part of an update, but whatever I thought i would just install the library and see if steam would start working again. After some googling I found that the missing package is obtained by:

sudo apt-get install libc6*

I found that most of the libraries were installed, except 1, and when I tried to install that library it gave the error:

The following NEW packages will be installed:
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
3 not fully installed or removed.
Need to get 0 B/1,265 kB of archives.
After this operation, 6,940 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 259004 files and directories currently installed.)
Preparing to unpack .../libc6-dev-i386_2.23-0ubuntu3_amd64.deb ...
Unpacking libc6-dev-i386 (2.23-0ubuntu3) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-i386_2.23-0ubuntu3_amd64.deb (--unpack):
trying to overwrite '/usr/include/bits', which is also in package libc6-dev-amd64:i386 2.23-0ubuntu3
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried googling this error, but it seems like a very generic error. Interestingly I found this forum post on another forum describing very similar symptoms to what I'm experiencing, however there was no fix suggested.

I've tried uninstalling and reinstalling steam, but because of the bootstrap error steam actually won't uninstall. Neither with sudo apt-get remove nor sudo apt-get purge. When attempting to reinstall steam ubuntu suggested that I run the command sudo apt-get -f install however this command attempts to fetch the libc6-dev-i386 package and fails with the error detailed previously.

On probably an unrelated side note, I did have the hack applied on my steam executable that allows steam to be closed to the tray without appearing in the bottom window tray.

I hope this is enough information provided, and thank you for any help.

The new Ubuntu seems to have broken their steam package, its common on other distros.

Try following this https://wiki.archlinux.org/index.php/Steam#Using_native_runtime