Kernel panic caused by VirtualGL/TurboVNC on 5950X in CentOS 7.7.1908

Has anybody here ever encountered a kernel panic caused by either VirtualGL and/or TurboVNC in CentOS 7.7.1908 on a Ryzen 5950X?

I’m trying to use VirtualGL/TurboVNC so that I can remote desktop into the system (and have a GUI) but that appears to be the source of the cause of the kernel panic that I am getting on my 5950X system that’s running CentOS 7.7.1908.

And if other have experience with this, what can I do to fix it?

Your help is greatly appreciated.


I am everything but an expert on things like this, but from what I understand in the picture it seems that something is trying to free memory and the address is a null pointer reference and then it crashes. I have no experience with VirtualGL, but instead of TurboVNC is would try another client.

Thank you.

Would you have a recommendation for another VNC client that will work in CentOS 7.7.1908 with the 5.15.11 kernel on a 5950X?

I am only asking because I’ve spent the past two days installing and re-installing the system each time it kernel panics like this using my 3930K (jumpstarting the system) so I am constantly pulling things into and out of both systems in order to try and get this system going.

So if you or someone else here has a more direct recommendation of something they’ve tried/used and was successful with it, that would be greatly recommended.

Thank you.

(It’s taken maybe at least about a dozen reinstalls to isolate that it’s either the turbovnc package and/or it’s the VirtualGL package that’s causing said kernel panic. Thanks.)

As I said I am far from being an expert on this, the last time I programmed something that could cause a kernel panic was eons ago. But the part with Kernel NULL pointer dereference is certainly and indication that there is code misbehaving and not working as intended. Using different software would be a quick fix to circumvent this problem. Since CentOS 7 is not the most up-to-date distribution you could also self compile a current version of the software if you really need it. The bug might have been fixed in the meantime.

Yeah, I tried downloading the latest and greatest version of VirtualGL/TurboVNC to no avail.

It was still having a problem.

So, I’m not really sure that I understand the root cause of the issue being that I don’t code, and therefore; I am unable to read and interpret code.

Thank you.

I finally found/figured out that it wasn’t VirtualGL/TurboVNC that was causing the kernel panic, but rather than “inbox” Infiniband driver that ships with the OS.

For some reason, it does NOT like the AMD Ryzen 9 5950X at all when paired with a ConnectX-4 dual port 100 Gbps Infiniband NIC (MCX456A-ECAT).

The moment that I try to install or update, for example, glibc, and then reboot - I will get a kernel panic.

1 Like