Kernel 4.3RC1 FGLRX and DKMS issues

Here we are again, trying to get the latest drivers working, and DKMS is here to stop me. I just don't understand DKMS or how to update it to Kernel 4.3RC1, it basically refuses to compile anything against the kernel with it.

Has anyone go any insider knowledge on howto update it? Completely lost as to what to do and I have been searching for hours. Tried everything I can find.

DKMS just doesn't care for Kernel 4.3RC1 or Kernel 4.2 infact. FGLRX NEEDS DKMS or it FAILS and causes desktop crashes 100% of the time.

PS. I'm doing this because FGLRX runs real slow in anything under kernel 4.2, for me. Yes I have had it working in the past, unknown how.

Managed to get some error messages, this one is upon installing the core module (I have tried running script sh installer also).

ERROR (dkms apport): kernel package linux-headers-4.3.0-040300rc1-generic is not supported

FGLRX Version 15.200.1 (development before 201)

DKMS make.log for fglrx-core-15.200.1

/var/lib/dkms/fglrx-core/15.200.1/build/2.6.x/firegl_public.c:195:22: fatal error: asm/i387.h: No such file or directory
#include "asm/i387.h"

(I have a kernel 4.2 patch for this, however I don't think it helps in 4.3?)

FGLRX Version 15.201 Catalyst 15.9 errors (little different, kernel 4.2 patch applied)

Creating symlink /var/lib/dkms/fglrx/15.201.1151/source ->
                 /usr/src/fglrx-15.201.1151

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
cd /var/lib/dkms/fglrx/15.201.1151/build; sh make.sh --nohints --uname_r=4.3.0-040300rc1-generic --norootcheck....(bad exit status: 1)
[Error] Kernel Module : Failed to build fglrx-15.201.1151 with DKMS
[Error] Kernel Module : Removing fglrx-15.201.1151 from DKMS

I do not have enough experience with the 4.X kernel to help you but whoever has will need more information. Like specs and distro etc...

Yeah, I do believe the FGLRX 15.20x.x driver will install with Kernel 4.2 if the buildfix_kernel_4.2.patch is used, but under Kernel 4.3 the error message is DKMS related. It maybe makes more sense then trying to install the FGLRX drivers without the patch, but something is missing still.

I could just go back to 4.2-exton but would rather not if solution can be found

You don't need DKMS. The Dell Kernel Module Management is just a versioning system for kernel modules and patches. You can install kernel modules manually no problem. The real problem is that the kernel modules themselves are not available... and that's COMPLETELY NORMAL, because Catalyst won't be used with kernel 4.3 any more in the same way, because kernel 4.3 already contains KMS-modules for AMD graphics.

So just keep the kernel like it is, and wait for the userspace driver that goes with the AMD KMS driver to pop up in the repos of your distro of choice...

That could take months, really what I'm experiencing is a crash, so if DKMS isn't whats causing the issue. Then something else is, I'll keep investigating, could be a problem with Cinnamon even... (loads in fallback mode)

You're not alone in experiencing troubles that are hard to diagnose. I've temporarily reverted to running Catalyst on a bog standard Vivid Vervet install because I didn't want to deal with the whole transistion from Catalyst to the new AMD driver system in OpenSuSE lolz. I'll just be using 'buntu until next month for those systems in which I need full OpenCL and OpenGL functionality. The systems with KMS drivers have not given any problem at all though, so if those suffice (and that will be the case for most graphics requirements, only for the hardest core games and for OpenCL, Catalyst would be required), you could just skip the entire Catalyst mess.

Yeah, well MDM error log says this:

modprobe: FATAL: Module fglrx not found.
(WW) fglrx: No matching Device section for instance (BusID PCI:[email protected]:0:1) found
modprobe: FATAL: Module fglrx not found.

However pretty sure I told it PCI card is on bus 6:0:0. not really sure why it can't find module since the drivers claim to have installed fine except for the DKMS nonsense.

There is no module fglrx to be found for kernel 4.3, because there aren't any binary blobs any more. DKMS just executes a modprobe like you would manually, but there is nothing to push lol...

Also because 4.3 isnt out yet.

@anon63470048 is there a reason you need 4.3?

I just seem to get better performance out of the later kernels with my 390x card. 3.13 kernel is poop. I might jump back to exton.

I wouldnt suggest a testing kernel unless you absolutely need something in it. 4.2 should do fine. The other thing I wanted to ask was what do you need from fglrx?

I hate fglrx its crap. I use the open drivers along with the latest mesa and libdrm and X etc. It works well.

Open drivers are incompatible with 90% of the titles I use, and Open drivers offer 1/3rd performance. Sorry.,

What games?

Its perfectly fine if that's the case, but the recent mesa bump means that a lot more games are compatible with the open drivers (Across the board amd, intel, nvidia). Effectively anything using OpenGL 4.1 or under now. Although yes the fglrx drivers have better performance (if they work, which they dont) the open drivers are perfectly capable as well in a large number of games.

dude, don't even try.

ARMA3
ARK
Dying Light,

There is quite a few in fact. And like I said I have tried open drivers before and on the few older games that it worked on, it had less then desirable performance. Anyway, not major. Will wait.

Use kolasa catalyst patches. About creating custom kernel and using catalyst:

Do you the status of AMD drivers on Opensue Leap. Seibert seems to be mum on the issue.

Well I'm using a ARCH Linux distro manjaro now so can easily install the latest kernels once something more solid is figured out. I did find a source for a fglrx with a series of patches and such from a AUR source, some people have it working with 4.2 at least.

https://aur.archlinux.org/packages/catalyst-test