KDE plasma 5 on Arch Linux

I have gotten pretty comfortable with linux, and i want to install Arch linux with KDE plasma 5. I can install Arch, but I don't know if i install kde plasma 5 during the arch installation, or if i do it after I have booted into the os. and I have never change the default desktop environment of an os, so how would i go about that.

You can install KDE plasma 5 after you installed the "base system" without rebooting.
I'd suggest you to use and read the Arch Wiki, it has everything you need. I'll just post some links:

On the beginners guide I've gotten to install and configure bootloader but this is what happens. See pictures. I tried both commands because idk if I have bios or uefi

I also the first picture happened at the end of installing the base system and the second picture is the error I get when I try to chroot.

You say youve installed Arch but this is the live iso.

What exactly have you done?

Have you setup networking? ping to find out.

did it do the base isntall, etc?

All those errors point to you having missed a step. (i presume the network isnt up based on the screenshots but its a guess)

i made sure my internet was working via ethernet by pinging google and it worked. then i went into parted and greated an mbr table on sda. then i partitioned it witha root boot swap and home partition. i mounted root to /mnt boot to /mnt/boot and home to /mnt/home. then i went to install the base system to /mnt, and you can see the error i got at the end of that in the pictures. then i generated an fstab. then i tried to chroot and it wouldn't work as seen in the last picture. the i did locale-gen and that worked. then i set my hostname and password. then i got to installing th ebootloader and that is the first picture.

What filesystem did you use for the (target) root partition?

The first image tells that you don't have the 'core', 'extra' & 'community' repos enabled, they're automatically enabled in /etc/pacman.conf, so you're prolly missing the conf file.
/etc/resolv.conf is your DNS conf, typically you'd want localhost 'nameserver' in it.

When you run arch-chroot, it automatically mounts /proc and makes /etc/resolv.conf available.
This type of errors

error: could not open file /mnt/var/cache/pacman/pkg/vi-1:050325-3-x86_64.pkg.tar.xz.part: Invalid argument
(more lines than the default buffer will hold)
error: could not open file /mnt/var/cache/pacman/pkg/vi-1:050325-3-x86_64.pkg.tar.xz.part: Invalid argument

may happen when you format the root dir as vfat.

The installation process failed, that's why he can't chroot into the installation.


it doesn't appear bootstrap was done correctly. for a simple mbr install with one drive all that is needed is / and a swap if there is 8GB of ram or less. i tend to match my ram size with 4 and 8, but would use 1.5x for 3GB or less of ram. 16GB or more, doesn't even need swap, but an 8GB will do if tradition is strong.

recreate the partitions and format the / dev as ext4, then mkswap and swapon the swap dev. mount /mnt on the / device (typically /dev/sda1, but not necessarily) and pacstrap. don't worry about /boot or /home, they will be made under / automatically. after pacstrap, do the genfstab, then chroot and all should be golden.