Ivy bridge Gigabyte mb won't boot to USB on startup

Hey guys,

I've got freenas running on a gigabyte z77x-ud5h motherboard (I know, it's not ecc memory. :cry ) and it keeps trying to boot off of the hard disk I have inside which returns the error:

"This is a NAS data disk and can not boot system. System halted."

I figured this could be traced back to the boot priorities in the bios and sure enough the WD drive keeps getting first priority, which is strange because prior to actually setting up the NAS target and volumes the rig would boot with the USB first every time.

Anyhow, I started playing with some settings trying to either to move up the USB in priority which would still boot to hard disk, or I try and disable the WD drive as boot option which causes a failed boot altogether.

I also attempted to have the USB emulate as an HDD in hopes it would be chosen, but no dice.

The only way I could seem to boot to the freenas usb was to press f12 on startup to enter the boot menu and launch freenas manually.

Any ideas? I probably just have my bios settings messed up. Not really sure what all this mumbo jumbo about legacy and uefi is all about.

per the man

(Boot Option Priorities)

Specifies the overall boot order from the available devices. For example, you can set hard drive as the
first priority (Boot Option #1) and DVD ROM drive as the second priority (Boot Option #2). The list only
displays the device with the highest priority for a specific type. For example, only hard drive defined as the
first priority on the Hard Drive BBS Priorities submenu will be presented here.
Removable storage devices that support GPT format will be prefixed with "UEFI:" string on the boot device
list. To boot from an operating system that supports GPT partitioning, select the device prefixed with "UEFI:"
Or if you want to install an operating system that supports GPT partitioning such as Windows 7 64-bit, select
the optical drive that contains the Windows 7 64-bit installation disk and is prefixed with "UEFI:" string.

[under Boot options Priorities , pick the drive to 1st boot ]

(Hard Drive/CD/DVD ROM Drive/Floppy Drive/Network Device BBS Priorities)

Specifies the boot order for a specific device type, such as hard drives, optical drives, floppy disk drives,
and devices that support Boot from LAN function, etc. Press on this item to enter the submenu that
presents the devices of the same type that are connected. This item is present only if at least one device
for this type is installed.

[Then select the Hard Drive under device BBS priorities]

another option bur not not sue if will work every time is to got to save and exit menu and do a boot override picking the device in the menu to boot however this may not work every time but it is worth tring.

Thank you ferg9020 for the clarifications. However I traced the problem to my bios resetting boot settings for some reason.

I'm not sure if it is the cmos battery because the date and time settings remain correct even after disconnecting the power cable and flipping the psu switch to the off position for over a week.

I noticed that even after saving profiles and doing save & exit, it will sometimes reset my boot settings the next time the machine is powered down. I'd say theres a 50/50 chance.

The only changes I had to do to have it boot through the FreeNas usb is under BIOS Features I set Boot Mode Selection to Legacy only, and set Boot Option Priorities to the freenas usb at the #1 position.

When you do a save and exit you will notice that boot override still indicates that the nas drives are the boot priority, which will cause a boot failure. So after saving the first time, you have to enter bios again before it boots and make sure that the usb stick is still the priority and that on the Save & Exit page the usb is a higher priority than the hard disks. If it isn't you have to try save and exit and enter bios to try again.

I notice that after saving this will continue to work and the freenas will boot from usb. However the moment I enter bios again, all my settings are lost except date and time, and boot priorities are reset.

Is this a bad MB / bios? My bios number is F19e.