Issues with installing new ssd in mbp

I have a Mid 2012 13" MBP, 2.9ghz i7. I've used carbon copy cloner, superduper and tried a clean install of Mavericks. Each time I cloned or installed to the SSD and reboot, the SSD will boot fine. The ssd is in a usb to sata enclosure. After installing the ssd into the drive bay inside the mbp, i will get a chime, a grey/beige screen and the mouse moves but nothing else. most of the time i dont get an apple symbol or the spinning thing. Im using a Kingston SSDNow V300 60gb. 


Is there some I am doing wrong when cloning or installing, is it just a bad drive or is there something everyone forgets to tell when making how to vids for cloning mac drives


The problem might be that our MBP doesn't support the controller in our ssd. I've got MBP 15' (late 2008) and when I upgraded its hhd to ssd, I remember reading that sandforce controller in many ssd (including Kingston v300) have had issues with macbooks. I am not sure does that apply to our computer, because it is quite a bit newer but that is one thing that might be wrong in our configuration.

I used samsung ssd because it has not a sandforce controller but later I ended up with some problems with that too. In the beginning it worked just fine, I splitted my computers startup time etc. but later I started to have some issues with starting the computer at all so I changed back to my original drive. I even tried some tricks like fresh install etc. but it didn't solve the problem.

I'd recommend to google if anyoine else had similar promlems. My theory with controller might be outdated (hopefully apple has done something for that) or then it just might a faulty drive.

I did basically the same. I copied everything with ccc and switched the drives. My mbp is from the same generation but with the base config i5. It's weird, that you got this problem, because I've got an Intel 520, which has the same SF-2281 controller.