Issues with Gigabyte B550M with Linux (Ubuntu 20.04)

At first I had a lot of network issues with Gigabyte B550M using Ubuntu (20.04).
I thought installing an offboard card and disabling lan on bios settings would solve it.
Since that, the machine hasn’t gone offline as it was happening before, but every +2 days on it simply becomes unresponsive.
I also found it difficult to hard reset even with the power button, and a few times taking off the power was the only solution.

I really do not know if it indeed becomes unresponsive, or if both keyboard/mouse simply stop working, as I have seen some posts about them not working with this board as well.

I have already tried manually changing kernel versions, without success. While some suggest newer versions, others suggest that it seems to be compatibility issues from version 5.4.xx on. It doesn’t seem that other linux distros work well either, but I haven’t tried myself any other than ubuntu.

Any suggestions?

It sounds like you have a problem with memory running out. Use the command line utility “htop” to keep an eye out on that.

As for your motherboard issues, have you installed latest BIOS? Try fwupd, if that is not up to the task you need to get more creative by utilizing, for instance, FreeDOS on a boot drive (or booting into a WIndows partition if you have one available).

Also, it would help if you are more specific than B550M as that only tells us it is an mATX motherboard from Gigabyte, currently Gigabyte has the following B550M variants:

  • Gigabyte Aorus B550M Pro AX
  • Gigabyte Aorus B550M Elite
  • Gigabyte B550M Gaming
  • Gigabyte B550M DS3H AC
  • Gigabyte B550M DS3H
  • Gigabyte B550M S2H
  • Gigabyte B550M H
1 Like

This is it:

  • Gigabyte B550M DS3H

And there is no chance it is a RAM issue. It has a total of 128 GB lol.

I have seen similar reports, but it also a different thing - for some the sound doesn’t work, or the keyboard/mouse, a lot of people had similiar network issues as I previously had using the onboard card.

I am not sure about the latest BIOS version, though. Will check and get it back here later.

Currently there is not a windows partition, and I would very much like to leave it like this. If nothing works, I am considering using windows+WSL, but this would be a last resource.

Ok, that model lacks a Flashback (or Q-Flash) option, then you need to do a quick FreeDOS hack:

  1. Find out which BIOS you are running (check BIOS settings)
  2. Install FreeDOS on a USB drive
  3. Download all later bios from the manufacturer website.
  4. Put bios files on FreeDOS drive
  5. Reboot into FreeDOS
  6. Run BIOS updates starting from the one you have +1:
    F1 → F2 → F3 → F10 → F12 → F13 → F14e

That should be it. Note that if you are on F10 you should update to F12, if F12 update to F13 et cetera.

Spec sheet for the model shows it supports both Q-Flash and Q-Flash Plus. He should be able to update directly from a USB flash drive in BIOS or by hitting the ‘End’ key on boot.

I’d try running it on a single stick of RAM for a few days to see if it makes a difference. Or let a memory test tool run overnight (multiple passes) just to rule out it being faulty RAM.

Right, my bad. Then:

  1. Format a USB drive with FAT32
  2. Download the proper bios from the manufacturer website (F13 for Linux/Windows 10, F14 for Windows 11).
  3. Transfer the BIOS file to your USB drive
  4. Rename the file to GIGABYTE.bin (IMPORTANT!)
  5. Make sure the USB drive is inserted in the port marked “Q-Flash”
  6. Turn off the computer and press the Q-Flash button. Do this while the computer has power but is in an off state.
  7. Wait for flash to stop blinking. Done.

Okay, let’ try this and see how it goes. I’ve just checked and I had F12 version installed and could successfully install F13 version. As per the manufacturer website, there does not seem to have any major fixing for this kind of issue, but who knows…

Maybe a relevant info, on another note, I missed out: my kernel version is <5.11.0-43-generic>
(I have already tried to manually change it before, to solve the network issues, and could not do it, so it is the same as installed along with this ubuntu version)

For kernel issues, you can get the latest available Ubuntu LTS kernel by installing the linux-generic-hwe package:

$ sudo apt install linux-generic-hwe

If you want the latest-and-greatest (please note, not stable!), then you need to manually compile. This is a lot more tricky on Ubuntu, but can be done. This is not recommended for any sort of productivity system however.

I would also try to strip down the system to a bare minimum and see if that helps things any.

They could use the Mainline tool provided through a PPA by the Ubuntu kernel team. Has a GUI and everything and there’s no need to manually compile. Of course it’s still not recommended to daily drive those kernels.

Which cpu do you run in this board?

It’s a MD Ryzen 9 5950X

I would like to avoid it s well (just like I would like to avoid using windows+wsl), but as for now I had tested a bunch of different things and nothing seems to work…

What filesystem are you using? 128 GB may be quite a lot of RAM, but a ZFS system is designed to gobble that up.

I am not sure about what you mean…
Is it what we see with “df -m”?

Filesystem Size Used Avail Use% Mounted on
udev 63G 0 63G 0% /dev
tmpfs 13G 2,2M 13G 1% /run
/dev/nvme0n1p2 916G 38G 832G 5% /
tmpfs 63G 1,7M 63G 1% /dev/shm
tmpfs 5,0M 4,0K 5,0M 1% /run/lock
tmpfs 63G 0 63G 0% /sys/fs/cgroup
/dev/loop0 128K 128K 0 100% /snap/bare/5
/dev/loop1 62M 62M 0 100% /snap/core20/1242
/dev/loop2 56M 56M 0 100% /snap/core18/2253
/dev/nvme0n1p1 511M 5,3M 506M 2% /boot/efi
/dev/loop3 66M 66M 0 100% /snap/gtk-common-themes/1519
/dev/loop4 65M 65M 0 100% /snap/gtk-common-themes/1514
/dev/loop5 62M 62M 0 100% /snap/core20/1270
/dev/loop6 55M 55M 0 100% /snap/snap-store/558
/dev/loop7 43M 43M 0 100% /snap/snapd/14066
/dev/loop8 219M 219M 0 100% /snap/gnome-3-34-1804/72
/dev/loop9 219M 219M 0 100% /snap/gnome-3-34-1804/77
/dev/loop10 248M 248M 0 100% /snap/gnome-3-38-2004/87
/dev/loop11 51M 51M 0 100% /snap/snap-store/547
/dev/loop12 56M 56M 0 100% /snap/core18/2246
/dev/loop13 44M 44M 0 100% /snap/snapd/14295
tmpfs 13G 20K 13G 1% /run/user/125
tmpfs 13G 44K 13G 1% /run/user/1000

Or is it something else? Sorry for the dummy question :slight_smile:

On a side note, if it was a RAM issue shouldn’t it be showing up at htop?
Recently (for example) I’ve been running something with all 16 cores, but RAM usage is around 14-16Gb of 128 Gb.

If you don’t know what ZFS is, do not worry - it is not enabled by default. Some users have enabled ZFS since they hear it is an “awesome technology” and fail to account for the amount of RAM it eats up.

You are correct about htop though, if it was a RAM fill issue it would’ve crept up.

Have you bought a proper cooler? That 5950X might just get way too hot for that motherboard.

hahaha okay I can’t judge :v

Yes, and it is a desktop equipped with 3 fans (okay some might argue pro water cooling bla bla), the whole set up seems fine in this sense. It does not seem to be overheating - it has been previously tested for it and I am also able to check the temperature. Now, for example (all 16 cores busy, machine is on for about ~23 hours):

Adapter: PCI adapter
Tctl: +61.0°C
Tdie: +61.0°C

Adapter: ACPI interface
temp1: +16.8°C (crit = +20.8°C)

Adapter: PCI adapter
Composite: +48.9°C (low = -5.2°C, high = +83.8°C)
(crit = +87.8°C)

Btw, funny thing is: it always stays on and with no problems for about 2 days.
2~3 days it works fine, then it freezes as I have described.

So I am still monitoring to see if the BIOS update I’ve made yesterday could make any difference. Guess I’ll be having fun with this during christmas dinner :stuck_out_tongue:

My main theories at this point:

  • Your CPU is overheating your VRMs on the motherboard.
  • One of your memory sticks are faulty.
  • A bad solder on the motherboard trips something up.

I would probably RMA that motherboard, at this point. Your issues sound consistent with a hardware problem of some sort.

1 Like