Return to Level1Techs.com

Issues with flashing DD-WRT on a TP Link Archer C9 v4 (a.k.a. Archer C1900)

#1

I’ve been postponing this update for a while, just waiting for the warranty to expire on my C9, and i casually remembered doing this today since the stock firmware on the router messed up and deleted the previous settings.
Well, i already run a secondary router (D-Link DIR-868L) as a wireless AP with DD-WRT and it has been working very well for over a year and a half, i’ve been thinkering around the web and i recently i found this article that i wanted to try out, and for that i also need to flash DD-WRT on my C9.
I’ve been trying to pick the files from here which seems to be correct, but all i get when i try to flash this file is an “unable to upgrade” message on the UI.
I did notice one thing about this, my C9 is an american model which has a larger sized stock firmware in comparison with the one DD-WRT provides, which itself is similar in size to the european stock firmware.
Could that be the reason for me not being able to update the firmware?
I tried multiple versions as well, just to make sure and the same thing happens.

0 Likes

#2

Update: So far i’ve tried everything that was reported on the DD WRT forums and wiki to flash this thing and i’m still not able to do it, i still think it has something to do the hardware version.

0 Likes

#3

Update, in case somebody stumbles on this thread in the future, here’s the reason why this update didn’t work.
Guess i’ll poach another router now.

0 Likes