Issues with a dell b1160w

I recently got bought a dell b1160w. I installed everything and tried printing a shipping label ebay and everything worked fine. But this evening i tried printing a large pdf and the system will not print what i am giving and turns out a sheet stating an "internal error- including Corrupted Data". I search fixes for it and all i could find was it was an issue with the the USB port. I then tried the system on an older usb 2.0 and 1.0 port and still received the same issue. Thoughts on how to resolve this?

when you print the pdf in the print options look for an option that says print as image then change it to what ever the opisit setting it is currently set to.

I dont have any options like that.

Is there a pdf to like open office system so i could try changing it to a word document?

open the PDF in adobe not in a browser then click print then click the advanced button the option should be there.

it is not.

that might work sometimes it f's up parts of the doc

so look it over after you convert it

hmm must only be on the pro version

can you print it to an xps first then print the XPS file?