Return to Level1Techs.com

Issues with 4x16GB on Threadripper 3970X

Hi everyone! Long time lurker (sorry!), huge fan of L1T youtube channel, and a fellow hardware reviewer. I need your help!
A couple of days ago AMD sent me a 3970X to test, together with a Zenith II Extreme. Once I set up my bench table with 2 32GB kits from G.Skill ( F4-3600C16D-32GTZNC), for a total of 64 GB, the system refused to boot up. I immediately thought about a motherboard related issue, but here I also have a TRX40 Creator from ASRock, and the same issue happened. No boot.
Then, I got the Z2E back on the bench table, and the OLED panel got stuck on the DEBUG code “Memory C5”, and right after that, “Memory Test” appeared on the OLED.

My memory kits are equipped with Hynix DJR dies, and I noticed that they’re not on the Memory QVL from both motherboards (ASRock TRX40 Creator and Zenith II Extreme).
Is it possible that the CPU is completely incompatible with these kits? Even running at JEDEC frequency?

When running two sticks only (in dual channel config) the system would boot up, install Windows and run benchmarks, although with very poor scores.

Thanks in advance for your help!

Bios updated? Will they boot at 3200? What if you lower IF clocks?

Latest version on the Zenith (0702), 1.10 on the Creator (I can’t boot even with 1 stick on that).
The systems don’t even boot up when all 4 sticks are installed, even after a CMOS (so with stock frequency for IF too).

I know some people had issues with earlier bios and ram support but I dont think I know of anyone having it that bad. I’m baffled on why tbh. Might just have to try another kit.

I only have different specs dual channel kits, unfortunately.

I’m running 4x16GB in my TRX40 system with a 3970X but it’s the Gigabyte Designare and Micron 3200 RAM. First boot took a while, with the RAM debug LED on, so I’m guessing it was DDR training, maybe give it more time?

I’m running 128GB of that exact kit, so I doubt compatibility is your issue. I’m even running it at 3733.

mem

I got the exact same problem with the exact same kit, though with 8x16GB DIMMs.

First, clear your CMOS by pushing the clear CMOS button and holding it for 30s. Power on and see if it fixes.

Otherwise re-seat your CPU; make sure that you apply equal mounting pressure to each side, take your time when installing. This solved the problem for me. I also reinstalled the DIMMs carefully to make sure that every DIMM is properly seated. One last thing, make sure that you use correct set of 4 DIMM slots on the motherboard (with 4 DIMMs, you are supposed to use those that are further away from the CPU; it is detailed in the manual).

I still have some problems though. First, the IF does not get past 3200MHz though I am able to run the DIMMs at 3800 with slightly relaxed timings. My biggest problem is that if I let the CPU at default settings, I get errors in prime95, but if I control the voltage and the frequency manually I manage to get a pass on prime95. Seems like the voltages for the default setting are not quite adequate. Any ideas?

What is your IF speed? Does it pass prime95 after say a 12h run?

1866, and yes.
(Setting to 1900 gets it stuck on memory test and I have to clear.)

Are you running the F4-3600C16D-32GTZNC or the F4-3600C16D-32GTZN ones? There’s a huge difference. The former have DJR, the latter B-die.

I’ll try this, but the fact that IF runs so slow doesn’t really encourage me :
I’ve used the proper amount of torque on the Torx screws thanks to the TR dedicated screwdriver, I tried the CPU in two different motherboards, and I checked every single DIMM. Everything is properly installed. For further info: I’m using an NH-U14S TR4-SP3 for cooling.

The ZIIE fails to pass “Memory Test” even when CMOS’d. But I’ll try again, I guess.

Different motherboard, different ICs.

I find Infinity Fabric is actually less stable on Linux when the CPU is idle. I can’t go above 1767 with my 3600X. Try idling on desktop on a Linux distro for 48 hours to test Infinity Fabric stability. If it crashes at all, it’s not stable.

Even when using a Live CD, I had data corruption issues during transfers at 1800 IF.

I am running a similar kit, F4-3600C16Q-64GTZNC, with a TR 3960x and the Gigabyte Aorus Master. I have no issues with the memory.

It’s also worth checking if it passes using a single DIMM first.

It works with 1 or 2 DIMMS, no matter which one I use of the 4 sticks I have. With that said, it may be worth checking what VSOC is used. Maybe dual rank 4 sticks is heavy in terms of current? I’ll check and come back to report. Thanks, in the meantime.

Just as a sanity check, you did try booting with 1 dimm in each slot to verify they all work?

Not in each slot, motherboards usually spit out issues when you don’t use the recommended slots. Also, the chance for two different motherboards from two different vendors to be faulty in the same way is highly unlikely.