Return to Level1Techs.com

Isolated Cpu Cores Not Boosting Fix

We are all familiar with this tweak in GRUB, sourced from ArchLinux wiki:

isolcpus=4-7 nohz_full=4-7 rcu_nocbs=4-7

However, if you look at the core frequencies you may notice that it is stuck at their base frequency.
You can use this command to validate:

watch -n.1 “cat /proc/cpuinfo | grep ‘^[c]pu M[hH]z’”

Or a slower version of the above with cpu core count.

watch -n.1 cpupower monitor

If that is the case, then try remove nohz_full first. If that didn’t work then remove that and rcu_nocbs.
If that also didn’t work then you can use redhat guide on using realtime tuned profile.
It allows cpu frequency boosting and isolate cpu cores.

If you use the realtime tuned profile, make sure you have extra space at the end of your GRUB command line, because it append additional settings.

1 Like