Is there ANYTHING to play on Linux/Wine/VirtualBox?

I'm specifically looking for some popular multiplayer games with a free trial to try out my new system on.

Doom 2016: Nope
Overwatch: Nope
Battlefield: Maybe
Firefall: Nope
WarFrame: ???
World of Warships: Maybe... with some crazy beta Wine stuff

EVE, Deus Ex, ARMA, Crysis???


I wish !

Through WINE

here's the Steam List for Linux :

1 Like

Battlefield 3 & 4 works fine in a virtualized environment with gpu passthrough with the appropriate hardware, tested with virt-manager


Cool, I was gonna be disappointed if I spent 2 hours DLing something (BF4) that doesn't work.

I have a full version of Win7Ultimate on VirtualBox and Mint 18. Do I need a different VM application and/or a different Distro? I'm still learning a lot of the command-line Wine things.

Distro doesn't matter. I dunno about Virtualbox, i've only used virt-manager

1 Like

Yep... all in all 16 entries for Linux demos :(

About Wine though, it seems Mint18 does not have new enough Wine to do WoT or WOWS. What is supposed to work?

compile it from source.

That was one of my frustrations with the Mint community, but it is a solid Distro otherwise

Anything Half-Life, Alien: Isolation, Metro Redux, The Witcher 2, two of the Trine games, X-COM 1 and 2, Tomb Raider, Torchlight II, DiRT Showdown, GRID Autosport, Middle Earth: Shadow of Mordor, ....

And those are just some of the better known games. I have 100+ titles for linux in my steam.

If you want some free GPU Pr0n online shooter style, the new Unreal Tournament can be run on linux as far as I know. But I haven't tried that yet.


There are a lot of games available. Just to name a few which I like: Civ V, TF2, CS:GO, War Thunder, Terraria, Factorio, Besiege, Saints Row: The Third, Saints Row 2 (Don't know how the port is, but there is an official Linux port).

1 Like

I know its probably not deliberate, but you make it sound like there arent any games. About 90% of the games I play are on Linux.

Granted I dont play battlefield much anymore. It just so happens the games you picked dont have Linux versions. (except ARMA)

EVE works well through wine.

And as mentioned you can play some of these with GPU pass-through on a VM.

This is why I dont like recommending these distros some times. Does mint seriously not have 1.8.3? Fedora has Wine 1.9.12, this is one of those packages where newer is always better.


I believe its older than that, but don't quote me on it...

Guild Wars 2 works quite well using Wine. F2P account with limitations but still a fun game.

1 Like

Yeah....The default packege is 1.6.x something....The same as ubuntu....That is why it is better to use playonlinux if possible on Mint/Ubuntu to get the most suitable version installed.

Yeah to clarify it's like @noenken said, I am specifically looking for some GPU porn FPS or TPS to experiment with. I'm kinda broke until the end of the month so I was looking for F2P or trial stuff.

Warframe has always worked like me.

World of Warcraft works well.

Dark Souls 1 (Dark Souls 2 has some graphical issues, but it plays)

Look at Steam's Linux catalog, a ton to play on there. 2500+ games at this point.

Theres tonnes of amazing games on linux, but if it isn't CoD or Battlefeild no one seems to care.

Yeah. Deus Ex, Dota, League, CS, lots of mmo's and RTS'. If you aren't a retard about it and try to learn how to use wine then you can play anything you want. You have to work for it, but it only makes it more enjoyable.

How are you playing WarFrame? It looks really pretty and I want to give it a try.

Lol, just saw my typo, derp.

I haven't played it in a month: but I can always rely on the latest wine-staging to work. Wine-staging adds things like CSMT patches to help improve performance.

If not, Playonlinux and trying different wine versions is a great option.

World of Tanks works on Mint 17.3 using PlayOnLininux+Wine, as World of Warships is the same people that should work too.

Warframe MSI:

Added Wine and PlayOnLinux PPAs and updated.

Wine 1.8 did not work. (Not sure how to get 1.8.4 specifically).

PlayOnLinux did not work with either 32bit or 64bit.