Is there any recent windows or AMD update that bricks Thunderbolt?

Had a UAD Apollo audio interface running fine through thunderbolt 3 for a couple weeks. Without touching anything, it is no longer being detected.

Processing: DAWSON UAD System profile.HTM…
Processing: DAWSON.nfo…
Could this be from a forced update? I’ve tried reinstalling drivers, rolling back windows and gpu driver updates, tried all bios versions and all 4 security levels for thunderbolt in bios, cable, updated win 10 to the latest version, tried windows 11 and the thunderbolt card is still seen by the computer, it just can’t see what’s plugged into it. the audio interface seems to be working fine as i can still pass audio through it and all the lights are doing what they should. Is there a registry edit I can do to force the thunderbolt card to look for and/or approve the interface?

5950x
6900xt
32gb cl15 3600
latest win 10 and win 11
asrock x570 taichi razer edition
gigabyte alpine ridge 2.0 thunderbolt 3 aic

Do you have another device you can check the UAD Apollo on to make sure it is the computer and not the UAD that has issues?

Also, welcome to the forums!

unfortunately not. I tried the included tb->dp cables with both of my monitors and those don’t show up either.

Sometimes absolutely nothing shows up when I click view attached thunderbolt devices, other times it shows the following

Thunderbolt Controller 1
Port 1
Port 2

but not the actual devices connected. I don’t know what causes it to show nothing or the above, but it seems to me like either the motherboard, aic, cable or uad device is faulty. Has anyone had this kind of failure before where it works fine for a few weeks then randomly never works again without making any changes to the hardware or software? The only other thing I can think of is forcing it to approve with a command line or reg edit. Is this possible? I’ll be sending the cable and AIC back first. If there’s no luck I’ll try the interface and probably just sell the whole PC and try a mac.

I have purchased a new cable and macbook pro. Worked fine with the new cable for 3 days then stopped again! Works fine on the macbook. It looks to me like the AIC isn’t powering up on startup. Nothing I plug into it works. Any tips? Faulty motherboard or aic?

I have purchased a usb-c dock to test the aic. it works fine through it, but the audio interface which is plugged in via thunderbolt is still not detected. i have my mouse plugged into the dock and noticed uninstalling the thunderbolt drivers didn’t affect the mouse, so it seems to me like it’s detecting the thunderbolt device as a usb device.