IPMI login failed

Don’t know what to add for the question except, I get to the log in screen, type the user name and password I configured in BIOS, and it just fails or gives 0 response. It’s an intel S1600JP4; intel considers it “discontinued” etc. and has been removing info from their website. Any ideas? I don’t have a clue what step to try next.

Anything useful in here? https://www.intel.com/content/dam/support/us/en/documents/motherboards/server/sb/545850_g68018_010_s1600jp_tps_r1_91.pdf

I have that PDF, thought intel pulled it because I couldn’t find it again. I’ve looked through it a few times, I don’t think there’s much for instructions. Couldn’t hurt to take another look though.

There’s like a bios reset thing, not sure if/how it affects ipmi login.

I’m not seeing anything that points to a solution. I have that system and the system I’m using to access it both on my desk, each with a monitor. I configured the BIOS, reset, then tried logging in. I waited for the system to reset and post before trying what I configured too. all I get is…

A low-level utility like ipmitool may give you a little more to go on (though IPMI is still cryptic at best), and allow you to (locally) configure some of the required IPMI settings.

With some really old intel BMCs I had to do some crazy low-level config to get IPMI to work:

ipmitool lan set 1 arp respond on
ipmitool lan set 1 auth ADMIN MD5
ipmitool lan set 1 access on
ipmitool channel setaccess 1 2 link=on ipmi=on callin=on privilege=4

I see you said that you tried using the configured creds, but did you try default creds? I believe it’s just admin admin for those Intel boards.

but with it being separate of the OS… Is that something that runs in EFI shell or what?

Some IPMI implementations have pretty short password length limitations and they’ll accept a long one when you set up the user but then either concatenate it or the user can’t log in at all.

Try a short password (like 6 alphanumeric chars) and if that works, try increasing size/complexity until it breaks again (so you know what the limit is).

No, you run it inside your OS. It talks to the BMC over the local bus. Inside your OS you can reboot the BMC just as from the BMC you can reboot your OS. Linux has ipmi driver modules that get loaded automatically when it detects a BMC:


This makes it possible for commands like:

ipmitool lan print

to show you and allow you to change the network parameters of the BMC/IPMI.

1 Like

I’ll look into that once I figure out why the system started boot looping.

BIOS reset and default root username with default superuser password failed the same.

welp, nothing seems to get me anywhere
I checked that plug n play BMC was enabled in BIOS

When in doubt, unplug the system’s power for a minute. That will power cycle the BMC.

You also need to run ipmitool as root, looks like you’re using it as a regular user there.

And the command you are looking for is modprobe. eg.

modprobe ipmi_devintf

But those should automatically load if your BMC is detected, and while I might try manually loading them, too, that doesn’t bode well.

no response, then same

Wait, sudo is admin and root is different? Or is my first guess right?


I’ll poke around not knowing what I’m doing for now, if anybody sees something, feel free chime in

sent cold reset command and chassis ID LED flashed, stayed solid and turned off. I assume that worked

Apparently not knowing what a “valid lan channel” is, is holding me back from poking around.