Interesting Win10 bug I got today

As of roughly 12AM PST, the win10 install on my desktop said it needed to be reactivated. I had to finish some work first so about 2 hours later I started to investigate the issue. Upon opening the activation window, I am greeted with Error Code: 0x004C003 under where the product key is listed. When using the troubleshooter below the error code, it says that the key I have is for Win10 Home and not Pro. This key has been working on Win10 Pro for 3+ years fine with multiple successful activations on a Pro version, not Home. After speaking with Microsoft support, they said that this is a known issue and the developer team is working on the issue. Q4 just isn’t Microsoft quarter for updates is it…


I haven’t been an Insider for nearly a Year now, but this exact same thing happened to me a year and a half a go when i was an Insider. They still haven’t fixed this yet? Dear god. In order to fix mine they insisted that I reformat. Which worked for about two months before it happened again. Was one of the reasons I dropped 10 for Win 7 for games that won’t run on Linux, and am mostly full time on Ubuntu 18.04.

Good luck. Hope this gets fixed for you. For me the straw that broke the camel’s back was the fact that every update for a solid month would fail, and I’d have to find the new ISO and re-install. I got sick of it.

Can confirm, this just happened to me too. In 2015 I upgraded to Windows 10 using my old WIndows 7 pro license. been using it without issues ever since.

No hardware changes, Windows just deactivated suddenly about an hour ago, and is now telling me that my license is a Windows 10 Home license.

Did they suddenly change something about the licensing?

Update: Just ran windows update and the activation issue has gone away. There were no updates to download so I have no insight for anyone reading this thread way down the line.

Microsoft had issues with their activation servers, pro licenses were deactivated and downgraded to Home, could also not be reactivated.
Insider Builds are Pro by nature, so naturally they were affected as well.

I noticed I had the activation alert last night, and after a reboot this morning it’s gone.

I also read somewhere that “Running the troubleshooter should resolve this issue”

i got deactivated but still kept my pro

Yep, seems like it got fixed. Ran the troubleshooter just now and got an “We’ve activated this copy of Windows” message.

And this is why for years I’ve said that activation via server is freaking stupid. They’ve had server screwups like this in the past. Should have been my first indication. But no, I kept going. Win 10 was the last straw. I now refuse to go back to 10 until they do something about every damned update breaking on my machine. I don’t have wild equipment. Mine is rather mundane. So it shouldn’t be all that hard for them to do something about it.

Do you still have the issue?
If they were not able to fix it I would probably do something drastic, but imho they dealt with, and fixed, this one really fast. Credit where credit is due and all that.

It’s not like a non-activated Windows is a big deal…
You can use everything aside from some personalisation options.

1 Like

@Vee , No i don’t anymore because i no longer use Win 10. But if I do, I’m making sure this is fixed before I use it.

@mihawk90 , For some people, like me for example, that is a big drawback. Many people like to customize their Windows how they want it.

Yup, I was affected by this on a fresh install, and couldn’t customize things. Things like making the taskbar smaller etc is a big deal for some of us.

Seriously considering the linux alternative atm, its not like I do much gaming anyway.

Gaming has become alot better in Linux. You’d be surprised. Especially with Steam and Steam Play.

Just don’t try to use DXVK with destiny 2 :joy:

1 Like

Oh it’s not like I don’t, I just mean you can continue using it because nothing critical is disabled

What puzzles me the most is why System != System in Windows 10.
Just try to search in Start, typing “systems” instead will yield exactly the result you’re looking for. Microsoft, please fix.