Return to Level1Techs.com

Intel X520-T2 10Gbit cards not working with Windows 10

I have booted into a temporary Linux distro to verify that I am not dealing with a hardware issue. I was recommended to come post here from the LTT community. In Windows the NIC shows up and will run a gigabit speeds, but will not run at 10 Gbps. In Linux it works fine.

Can you try to set the link speed manually in the properties of the adapter?
2021.10.06_01:11:40_VXxSyduEX3

How to get there:
Windows+R > ncpa.cpl > Right click on the adapter > Properties > Configure… > Advanced > Link Speed

Unfortunately those options don’t show up.!

not an option

When I look in Task Manager it shows the adapter is “Paused” but it still runs a 1.0 Gbps.

Also, on my switch the connection shows up as 10Gbps.

Switch

Are your drivers up to date?
Can you downgrade drivers?
Are there beta drivers available from Intel?

1 Like

Interesting… I have the same adapter and when I ran Windows 10 it worked right out of the gate.

Are you using DAC or fiber?

Do you have a 1Gb connection as well? If so when you test the connection is traffic showing on the x520 card or not?

1 Like

@David_Farris Last Christmas, I purchased an Intell X350 T4 and had a hell of a time installing it in Windows; finally, after five hours of installing different drivers working in Windows. The funny thing was on Linux; I didn’t need to install drivers, and when I booted the same machine up, the ethernet card just worked. So the only thing I can suggest is to keep trying different drivers.

1 Like

There are (2) 1.0Gb NICs(Intel I211) on the motherboard(Asus X99 Deluxe) and the X520-T2 witch has 2 ports.

I am using the 10Gigabit ethernet version, so neither DAC nor Fiber, it is connected via CAT6 to a Ubiqiti USW-Flex-XG which show it is connected at 10Gbps. Its only Windows that shows 1.0Gb and is limited to that speed.
Switch

@David_Farris
Do you see activity going through the x520-t2?

Honestly if you wanted to go with CAT6, it would have been way better to go with something like a X550-T2. With the X520 being an SFP+ card, it might have something to do with the module you’re using. I know you said linux seemed to work fine but was it coincidence or not is what I wonder.

You could try disconnecting and reconnecting the network cable a couple times just to see if it will properly negotiate a 10Gb connection. You also might try (if possible) locking the switch to only use 10Gb on that port. Even if your switch says it’s 10Gb, if the connection isn’t working, you won’t truly know which one is lying.

1 Like

@Razor_Blade
I am posting this response through the card, this is not the SPF+ version. It is natively RJ-45

I have tried unplugging and re-plugging several times to no avail.

Thoughts?

For some reason I am disallowed from linking to Intel’s product spec page. Or any links for that matter.

You’re right I was thinking of the x520-DA2

If you only have the one cable going to the x520-t2 do you get a connection? Microsoft does strange things with network cards sometimes that makes me suspect driver issue as others here have said.

I wish I knew more about the intel Ethernet
Converged adapters as I’ve only dealt with “Dell” branded Broadcom cards.

All I could suggest is if you’ve already tried the intel driver, see if Microsoft update has a driver that works (i.e. uninstall the driver you have now and let Windows update find one) then check the version of that driver to see if it is different from what is on intel’s website.

The device I am on now is only connected to the network via 1 CAT6 ethernet cable.

I have tried all of the steps you mentioned.

@David_Farris, have you tried the auto-negotiation option to fix your issue.

@David_Farris As I understand your situation, the Intel X50-T2 is working but only at 1-gigabit speeds. Is that the situation? Have a check to see if Windows 10 is using Jumbo frames. I read an article (it’s been a few years) you have to set Junbo frames for 10-gigabit to work correctly manually.

I think your issue has two possible causes, either the Ubiquiti USW-Flex-XG isn’t passing the information a 10-gigabit card is being used, or the problem lies with Windows 10. It might help if you post a Network map of your Network to get a better idea of how your network packets should flow. I don’t know a lot about Windows; I am more of a Linux guy. Let me page @Novasty I think he is the Windows 10 expert on the forum for Windows.

1 Like

Just making sure, you did download the latest driver available for it right?

3 Likes

@Shadowbane yes, the X520-T2 is only working at gigabit speed in Windows, I have booted a thumb drive Linux distro and the card operated just fine at 10Gbit. The switch sees the connection as 10Gbit. I have tried Jumbo frames on and off with no change.

Sorry for the delayed response, I have been swamped at work and have been dealing with some family medical issues.

There are (2) 1.0Gb NICs(Intel I211) on the motherboard(Asus X99 Deluxe) and the X520-T2 witch has 2 ports.

I am using the 10Gigabit ethernet version, so neither DAC nor Fiber, it is connected via CAT6 to a Ubiqiti USW-Flex-XG which show it is connected at 10Gbps. Its only Windows that shows 1.0Gb and is limited to that speed.
Switch

@Novasty installed

@Shadowbane missed the post about auto negotiation; yes I’ve tried that it did not change any behavior.

You should probably contact Intel support at this point…

1 Like