Return to Level1Techs.com

Installing ubuntu 18.04 missing grub


#1

I’m currently working on several IBM desktops that we are going to use for a charity. I’m trying to get Ubuntu 18.04 installed and as I’ve tried several installs, I notice that the first attempt fails. Ubuntu installs, but grub doesn’t.

If I install it again, then it works. Since we’re using this as a teaching tool, I don’t want to force students to have to install ubuntu twice. Currently, the disks have blanked NTFS partitions. The desktops are ThinkCentre i5 systems, M series.

I’m trying to sort out how best to handle this. Hopefully, I don’t have to repartition each hard disk before we have the students install Linux.

In any case, I’m not sure what’s causing it, so I was hoping for a tip or two to start troubleshooting…


#2

Just out of curiosity which drive are you installing to when it asks. Are you using the full drive?


#3

Yes. There’s only one partition and I’m just telling it to erase and install ubuntu. I had tried playing around with partitioning, but it didn’t seem to make a difference, though I don’t know what, exactly I did anymore.

That said, I have 26 more of these systems to test on, so I can grab another and try again, but I wanted to get some other opinions rather than just randomly guess…