Installing Linux on Dell Precision M65

Hello everyone,

I've finally decided to switch to Linux on my backup computer, but with little to no progress so far.

Let's start with specs - it's an old workstation laptop, Dell Precision M65 with Core 2 Duo T7200, 3GB DDR2, nVidia Quadro FX 350M, and 320GB SATA hard drive.
If it's anyhow relevant, it also has 15.4" screen with resolution 1920x1200, which is why I'm still using it.

So far I've tried these:

  • Ubuntu (Unity) 14.04.2 - made most progress with it, installed without problems, but when I boot it there are no side icons or other elements, just blank desktop. Tried several solutions that suggested resetting Unity, but none really helped, either desktop stays empty, or screen switches to artifacts
  • Ubuntu (Gnome) 14.10 - as soon as loading logo disappears, screen gets artifacts and I can't even install it
  • Xubuntu 14.10 - same as Ubuntu Gnome

My guess is that problem is related to graphic card drivers, tried updating them via terminal, but that also didn't help.
Any suggestions?

I recently went through the same process with my own system, a desktop however, in installing drivers for a fairly old nvidia card on stock debian linux. As Ubuntu is Debian with some extra stuff added on, I believe the instructions should work for you, however you may have to perform them in a command line. If you have any issues with that, be sure to let me know, but you can fine the install instructions here.

Can you please write console commands for that instructions? I'm noob for Linux and only know few basic commands.

I followed another lead yesterday which is related to known bug for bad dependencies between driver and linux headers, and it slightly improved situation, but it's still not functional. It now shows desktop elements, but they are blank squares and everything except terminal is unresponsive.

1 Like

do you have another GPU you can try?

edit* laptop nvrmnd...

I know that Linux runs without problems on desktops with Intel HD4000 (i5-3570K) and Intel GMA (Intel Atom mITX board), so it's likely related to Quadro FX 350M. Unfortunately, M65 does not have second GPU.

Problem is related to GPU lockup, but I can't find good drivers, latest nvidia drivers are not working well even after fixed dependencies.

when I VM linux on my qnap I had to update Ubuntu. becuase it was giving me graphic problems as well. try updating ubuntu or whatever distro.

I've already updated it, so that's not problem.

Since picture is worth 1000 words, this is what I have now when I log in:

I can't click on any of those icons on a side panel.

Update: Installed Lubuntu 14.10, everything works right away. Thus my journey into world of Linux starts... :)

Thanks for all the help.

Nice, glad to hear