Installing Linux on a New HP Omen Desktop

I recently bought one of hp’s latest OMEN PCs, for the first time, (notice “bought” instead of “built” i.e. n00b) and I was looking for something that’s decent for small-mid size AI workloads. For someone who has been always using Linux on laptops, I thought installing Linux wouldn’t be that different on a PC. Create a bootable Linux USB, change boot order in the BIOS and the rest is doughnuts. So I prepared the USB, changed the boot order, and this is what I get:
ima: Error Communicating to TPM chip

So I set the TPM option to Hidden, reboot, and I get a blank (teared) screen with badly distorted unreadable text.

here is the specs:

  • intel’s i9 10900K
  • HyperX XMP 64 GB
  • NVIDIA 2080 RTX Ti
  • Intel Z490 motherboard by Dorado OC

with a machine that’s more on the pricey side, and even after installing the latest updates of windows 10 2004, NVIDIA 455 drivers; the system is far from stable. This is why I’m disparate for help to get Linux running.

any help is appreciated

1 Like

Which version of Linux?

You’ll likely need to do the nomodeset trick to get output.

If you’re having stability issues in windows, Linux is unlikely to solve this.

Ubuntu 20.04

I’m having two main problems: the infinite bootloop when powering up the machine (or restart it after an update), and second, the sudden shutdown of the monitor after a youtube video ends (only on google chrome), and for this I have to unplug the HDMI cable from the GPU end, and put it back in to get the screen back on. For the bootloop issue, I just keep on pressing the power button (powering up and shutting down) a few times until windows shows up.

I am hoping that these two issues are software-related and they would disappear once I get Ubuntu installed.

It sounds like you might have a memory issue. The repeated reboots sounds like memory training.

The GPU/monitor issue is pretty strange to me. Can’t say I have a clue what’s happening with that.

I would RMA that machine because neither of these sound like software issues to be honest.

1 Like

If an OEM system is not stable out of the box (or after updates in this case), I would not fuck around (especially with a technically unsupported OS) and just call them up. Especially at that price range that shouldn’t be tolerated. That is literally their job and what you are paying the premium for on an OEM machine.

When the system is stable out of the box you can still think about replacing the OS.

you are better off returning the computer, building it yourself or buying a preconfigured one from companies like System76 or Lambdalabs

1 Like


After writing the original post, I made two things:
1 - I upgraded windows 10 from version 2004 to the 20H2 release ( originally thought it might not be a stable version, but I discovered that it was just a minor upgrade to version 2004) … and this seems to have solved the bootloop issue … fingers crossed

2 - I saw that NVIDIA had two driver options for the RTX 2080: a “Game Ready Driver” and “Studio Driver” … I switched to the studio driver … and the monitor problem is apparently fixed.

still no luck in getting the computer to boot from the USB … I tested the memory stick on a laptop, and Ubuntu is recognized perfectly … not on the PC, though :persevere:

try some other distro?

You need to disable SecureBoot and TPM.

IIRC the “hide” option is on another page, it just literally hides the setting so anyone entering the BIOS can’t change it.

Set it to “show” or whatever (in fact, I’d say set all of them to show, why would you hide stuff from yourself), then look in other settings and find TPM/Intel Trust Platform and disable it (I reckon you don’t need it? I never used it)

The infinite bootloop can happen after a botched W10 update, as for the graphics problems, could be hybrid graphics. Or both could be caused by a hardware issue.

Try to add nomodeset to the kernel command line (boot parameters) in GRUB by pressing E when the entry for trying Ubuntu is highlighted. If that doesn’t work, then we’re essentially back to square one.

Hm… I’ve never had TPM issues on Linux, so I’d only hide that if nothing else works. Ubuntu supports Secure Boot, so that shouldn’t necessarily be an issue either, but I could see it being one when booting from a USB stick.


I tried all tricks mentioned so far:

  • another distro
  • disable SecureBoot and TPM

for the nomodeset trick, the grub menu is not even loaded on startup!

I changed the boot order from the BIOS, to boot from the usb drive; yet when booting up it either go straight to Windows (usb ignored), or the bootloop happens (yes, the update didn’t fix it unfortunately). I suspect this has to do with “Dorado OC” motherboard or the way it was configured out of the box.

Have you talked to their support about the Bootloop? I would not fiddle around with that this much, in that price range. That’s their job to figure out TBH.

I did talk to HP support, and they suggested that I take it back to the store where I bought it from. I’m not in the US, and I’m trying to keep this as the last resort, since this is the only computer I have right now, and the bootloop problem happens only when there’s a usb stick plugged, or when I try to hit f10 repeatedly to get to the BIOS settings (even in these 2 cases, it happens occasionally). So I think I can wait for some update from windows or hp that will fix this issue for good; but for now, I just want to find a way to have grub recognized.

Try using a Windows LTSC build, if i’m not mistaken they’re supposed to be the most stable Windows builds. If even that doesn’t work, you should replace the whole computer or cut your losses and get a cheaper Z490 motherboard, depending on how quickly you need a working, stable computer.

Could you make a recording of your process of attempting to boot into an Ubuntu LiveUSB? There might be some clue hidden in there.

I’ve been using linux for years, not a power user though, just an amateur developer, and these simple steps has always worked for me:

1- download x86 image of latest ubuntu 20.04
2- create a bootable usb with balenaEtcher (also tried UNetBootin, rufus)
3- Change BIOS boot sequence and put USB Drive on top
4- Shut down the PC
5- plug the usb
6- power up

Followed same steps twice, once using Ubuntu 20.04 and another one using Fedora 32 on two different usb drives. Every time the usb isn’t recognized on the PC, I try it on my old laptop or that of my friend, and grub is recognized perfectly, and installation goes as normal.


All right. I’m now interested in what exactly shows up on the screen when it enters a bootloop. Does it enter one with the USB, or…?


Maybe trying a rolling-release distribution might help. At this point, I’m grasping for straws.

A year later update:

It seems like this issue requires making changes to multiple UEFI settings before the BIOS can even recognize and boot from the USB stick.

source: Solved: Can't use Linux on HP Desktop - HP Support Community - 8148188