Return to Level1Techs.com

Installing 2nd NVMe SSD made my primary unbootable

Hello,

My computer was running just fine for almost two months now. Today I tried to install another 1tb NVMe SSD.

I went into the BIOS to check the boot order. Ended up turning on XMP and virtualization as well. This caused boot loop with the BIOS and keyboard inputs freaking out.

  • BIOS was on F3. I tried clearing CMOS and reseating both SSD.
  • Ended up flashing new BIOS. So I am now on F6b.

It’s working normally I believe, I haven’t changed anything from default except Boot Order.

I still cannot boot into Windows.

I have tried:

  • a Linux boot USB and checked the primary SSD is still accessible.
  • a Windows boot USB to try to “Repair Startup” option.
  • booting with only the one NVMe SSD.
  • changing the M.2 slot from A to B on the board.

My long weekend is ruined, I have no idea what my next steps are. I am afraid of having to install Windows and all my software all over again. Is there anything you would suggest?

At this point I am unsure if I should install Windows on the Silicon Power drive and use the WD drive as the secondary.

Any help is appreciated. Please let me know what other information I can provide.

My specs:

Aorus X570 Ultra

AMD 3800X

GSkill 32GB RAM

RTX 2080

1 3TB HDD, 1 2TB HDD

Primary Windows

WD_Black SN750 1TB NVMe Internal Gaming SSD - Gen3 PCIe, M.2 2280, 3D NAND, Up to 3470 MB/s - WDS100T3X0C
New Secondary

Silicon Power 1TB NVMe PCIe Gen3x4 M.2 2280 TLC R/W up to 3,400/3,000MB/s SSD (SU001TBP34A80M28AB)

Remove the new ssd and see if you are able to boot and if not, try to repair the bootloader from a windows usb install

Those are things I have already tried.

What error do you get when booting?

The “no bootable media … restart or select media” text error. I am uncertain when this could have happened as the thing that happened was BIOS problems.

Boot into linux and try os-prober, see it can detect the windows efi

Sorry, do you have a guide to follow? I couldn’t find anything that made sense to me. My USB has Ubuntu 18.04. The WiFi isn’t working, I don’t know if it is something I need to install.

Change your BIOS back to default and try to boot to Windows

Yes, that was tried.

So you tried the windows recovery tool and it couldn’t find your install?

I tried this.

Why are you creating partitions if you’re trying to boot to an existing partition?

And why are you trying to solve this in cmd?

I am trying to fix my partition.

How else can I solve this? Gparted in Ubuntu? Instruction guides for these keep bringing up dual boot/gpt.

Can you provide some suggestions to help me?

What made you come to the conclusion that something is wrong with the partition? The partition shouldn’t have any problems unless you did something to it.

Take a picture of your boot options after pressing F11 or whatever yours is.

I keep trying to boot into my drive. One of the pictures shows the partitions are there and active but selecting the drive to boot is not working. I searched some stuff about how to find windows efi and came to some guides on boot recovery.

I removed all my extra drives. Keep getting this.

Do you have a windows installer on a usb anywhere? You need to boot to that and recover.

That’s where the cmd pictures were from. I tried the automated repair. It’s not working.

Try installation then and select keep files and other stuff. Just reinstall and save all your important stuff.