Install overwatch

Hi, Yesterday, I managed to get all my windows library working on linux perfectly - expect one game, overwatch. Lutris offers me 2 options of installation dxvk and wine. First of all I dont know which one is better for me (running gtx 1060) so first i tried dxvk. Installed all dependencies from, but battle net didnt even open because of dll missing. The same site has a solution - install 32bit drivers and vulkan 32 bit. I dont know how to do any of those so i removed battlenet and tried wine version. I got a little bit further, lauched but i cannot install overwatch im stuck there:

. it this process goes forever and ow in not getting installed. Now I am out of my options so pls guys help me out how to install ow and which option is best for me.

To get the vulkan libs needed for DXVK with nvidia, install these.

sudo apt install libvulkan1 libvulkan1:i386 

I already have those and I had those from the beginning. says if i get error A required DLL could not be found …(solution) If using OpenGL: Make sure you have 32 bit drivers installed (Blizzard App is 32 bit)

If using DXVK, and it works with OpenGL: Make sure you install Vulkan correctly, including 32 bit

and i have neither of those 32bit things. I dont know what causes my problem but i want to have it solved.

Which is it?

You do know that you have to have the 32bit libs regardless right?

Well I used this command (sudo apt install libvulkan1 libvulkan1:i386 ) so What i think I have 64 bit vulkan librares installed. But i dont know how to get those 32bit

If you did that command, then you will have both of them installed.

i3:86 is 32bit.

than I have no idea why my dxvk instllation is not working

You are on Ubuntu yes?

yes, 18,04

Alright so after install the needed stuff for vulkan, in the guide you linked you then needed to install these:

sudo apt install -qy libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libsqlite3-0:i386

After installing these check for updates and then reboot.

sudo apt update && sudo apt upgrade -qy && sudo shutdown -r now

And then keep in mind this caveat since you’re using nvidia.

When you install the nvidia-driver package, it might not necessarily install the 32-bit libraries, which is a problem because is a 32-bit app. Check your distro documentation for the correct packages.

So, I did those first 2 things you mentioned, but i dont understand the 3rd line

I have had this problem too and I highly recommend reading this post–issues-with-installing–updating- (which I know you have based on previous responses) but pay close attention to the section Sleeping Agent / issues with installing / updating and be sure to delete the folders mentioned…