'Inaccessible Boot Device' BSOD on New Asrock x470, R7 2700 Build

New build for my stepfather. Here I am spending my Sunday troubleshooting it after installing drivers and performing a Windows update.

CPU: Ryzen R7 2700

Motherboard: Asrock x470 Master SLI/AC

Memory: 2x 8GB G.Skill Aegis 3000MHz


Storage: Samsung 970 EVO 250GB (Windows is installed here, NVMe), 1TB WD Caviar Blue

I’d run several rounds of updates previously without any problem. The BSOD loop started after I’d installed all of the latest drivers off of Asrock’s website including the AMD chipset driver, ethernet controller, WiFi controller, Bluetooth driver, AMD RAID driver, sound driver, floppy driver of all things, in addition to another Windows update.

I’ve tried startup repair, system restore, go back to previous version, clear CMOS, updating the BIOS to the latest one on Asrock’s website. Not sure what to do. I don’t even have access to safe mode.

I do have access to the command prompt via the blue startup repair menu, but I don’t really know my way around DISM well enough to know what needs to be done.

I would just clean install since there’s not really much on it yet, but my stepfather is pretty tech illiterate and real keen on having the latest windows updates. Please help if you can. Any advice is much appreciated.

Seems to me that you suspect it being windows update

I would just install that Win10 again, and then do the same except, load Intel drivers from Intel, and AMD from AMD, because thats what I do anyways, then :man_shrugging:t2:

Update: Out of desperation, I retried “Go back to previous version” on the advanced startup menu and it didn’t present any errors. I’ve installed all available Windows updates and reinstalled the drivers in that order.

I did skip installing the AMD RAID utility and floppy driver this time as I’m sure he won’t be using them and who knows - they may have been causing some esoteric problem. I also grabbed the AMD chipset driver from AMD’s website rather than Asrock’s.

Now to convince him that his copy of AutoCAD Architectural Desktop 3.3 from 2001 is not going to work and I’m free :smiley:

Apparently this is a thing: https://www.longbowsoftware.com/

The Longbow Converter App: Run old versions of AutoCAD on Windows 7, Windows 8 and Windows 10
The Longbow Converter is a tool which allows old versions of AutoCAD to install and run natively on new versions of Windows 64bit breathing real life back into your old copy of AutoCAD

1 Like

I’ve actually seen the Longbow Converter thing. I appreciate it and I will suggest that he try this.

Of course the stupid program worked for 5 minutes after we initially installed Windows, so he’ll probably accuse me of screwing something up during my 6 hours of free technical support :roll_eyes:

Just spits out memory-related errors no matter what kind of compatibility mode I try. He could probably run it in an XP VM, but that’d just be another thing for me to set up.

It’s ancient, out of date and unsupported so he’ll either have to suck it up and get the Longbow program or update his software.