In Desperate Need of Help with New Build

Hello all,

This is long but hoping someone can help me. Just put together a new build and I’m having some troubles with it that I cannot solve. Any help would be greatly appreciated as Googling things for hours doesn’t seem to lead me to any solution.

CPU: Ryzen 7 3700x
CPU Cooler: Noctua NH-U12s Black
Mobo: ASRock B550 Taichi (Using the 1.00 Bios)
Memory: G.Skill Trident Z Neo 16gb 3600
GPU: MSI Geforce RTX 2080 Super Gaming X Trio
PSU: Corsair RM850x
Storage: Samsung 970 Evo Plus 1TB
Samsung 860 Evo 1TB

This is my second PC build. First one in 6 years. Setup/first boot went just fine. Installed Windows just fine. Installed chipset drivers. Then installed the latest Nvidia drivers. Everything went just fine with plenty of restarts and booting in between.

After some light use the PC began showing some issues. Firstly, intermittently, the PC will fail to boot from restart or cold start. It will power on fully with all lights and fans but will show nothing on the screen and will display an “8d” post code on the motherboard. Trying to reboot it again will require me to cut off power at the PSU. Sometimes. Sometimes it’ll boot up normally. I have done all I can trying to find what this post code is and cannot come up with a clear answer.

It will also lock up randomly, and I do mean RANDOMLY. It’s locked up while browsing chrome, while playing a game on Steam and even while sitting with literally nothing open, just a blank desktop. This will require a hard shutdown/restart and sometimes will not boot back up without cutting power like with the 8d post code. I have no way to replicate either of these issues. They are totally random.

First someone suggested it was the memory. Tried using the PC both using the XMP profile from the BIOS and with it at default speeds. Tried removing and reinstalling it and running memory test on it several times with everything looking great. Did not solve the issue.

After that, someone suggested it may be the PSU. I’m not sure how to even test for this. Everything is plugged in correctly. I have two individual cables running to my GPU from the power supply instead of daisy chaining(I think is the term?) from one single cable. Not sure what else to try for this one. I am in talks with Corsair support but they don’t see anything wrong with the PSU with what’s going on.

I guess aside from some sort of issue with the mobo the only other thing could be the CPU. I don’t know how to test this either. Someone suggested reinstalling the CPU. I haven’t done this yet but not sure how it would help unless there’s a reason that would help that I’m missing.

I’ve thought about updating the BIOS but I’ve been terrified of doing that as multiple friends of mine have messed up their boards doing it incorrectly. Not sure if that would help the issue either.

If there is any other information I can give let me know. Again, any help is appreciated. If there is some sort of hardware issue here I’d like to either know which part it is to try and RMA or if it isn’t hardware related I’d love to fix it so I can actually use the dang thing.

Your motherboard manual should list the post codes. Is it ALWAYS 8d?

Look in there and report back what “8d” is listed as.

It isn’t in the manual unfortunately. In fact, there aren’t any codes in any of the literature with the B550 Taichi.


Would indicate a chipset initialisation problem.

Clear CMOS, try again (I’d leave all settings at default to test initially), failing that maybe RMA board. If it won’t boot/post successfully with out of the box/cleared settings, RMA it.

source: Asrock web site. My Taichi x470 has debug codes listed in the manual (but it is at home, and I am not). Odd that yours does not. Presumably all ASRock codes are the same/standard across their product line (above source didn’t seem to indicate otherwise). Otherwise Asrock are insane.

one other thing. You did make sure that the heat-sink doesn’t have any cover on it, thermal paste was there, etc.? If you can get into BIOS, check CPU temps in there to see they’re not insane while in BIOS.


Looks like a ram issue to me ?

Ram issue according to dr debug would start with B, not 8 :slight_smile:

Your motherboard has its supplemental 6/8 pin power connected, etc.?

1 thru 54 with letter being not so important in an odd slap happy way.

Ah yeah I missed they were also memory. Either way 8d falls within the “chipset problem” range. Not much you can do about those it seems?

Temps seem fine both in BIOS and Windows. Will try clearing CMOS and going from there.

I am just not seeing that ram listed. Which might mean some ram tinkering.

I thought that too but I’ve seen multiple people with even the 3800 G.Skill Neo ram running it perfectly stable.

It does not mean you can not get it to work ? It does mean you might have to sort your own ram timings. A little something to ram validation in regards to ease of use.

Any RAM (assuming it is DDR4, etc.) should still work at non-XMP speeds. Just because it isn’t on the QVL, doesn’t mean it won’t work at stock speed. That’s just for XMP rated speeds.

Leave the settings alone and turn XMP profiles off, run it at 2133 or whatever it defaults to (non-XMP settings are slow/conservative) until you get the boot problems sorted out reliably.

I don’t think its a RAM problem, but right now you want the machine to run as conservatively as possible to isolate any potential hardware defect on the actual board…

Yes I’m keeping XMP off for the time being.

Also, it just learned a new trick after posting this where it will straight up restart on it’s own out of nowhere. So that’s neat.

Definitely make sure there are no electrical shorts - no stray motherboard stand offs where they shouldn’t be, etc. I.e., pull the board out of the case, make sure you have holes in the board for every stand-off, and if necessary remove ones that shouldn’t be there from the case. Otherwise they may be contacting traces/components on the board.

That can definitely cause the wierd/random behaviour like that (amongst other things).

I’m gonna try taking it apart and redoing it and trying to boot to see if that helps. Could a short cause all of these problems? Never had the issue before so I’m not well versed in it.

Could it also be a software issue of some sort? Everything worked flawlessly basically until I installed all the drivers for everything.

Depends what is shorting.

Could be a couple of pins on a memory socket, could be a dodgy ground, all sorts of random issues can happen depending on what is contacting what.

I’m not saying its a 100% cert for the problem, but I’ve seen some really wierd case/mounting related issues before - and its something that is often totally off the troubleshooting radar for most people.

Personally, I think you may need to RMA the board eventually, but you don’t want to do that if its something you have the ability to fix :slight_smile: