I screwed up my boot sector, help? (Semi-Urgent)

Okay, so here's a list of things gone from bad to worse.

I got a samsung 128GB SD card, it was acting up, I started to go blindly into trying to fix it in various ways.
I accidentally somehow made it into a RAW format, and since windows doesn't want to deal with RAW, I found this and was following it.

I was trying to wipe the drive clean before attempting to somehow format it back to NTFS using the program suggested in the reply. Unfortunately for me, I made a mistake and somehow misunderstood my 128GB SD card for my main 128GB SSD. After a but of tinkering on what at the time I thought to be my 128GB SD card, it said reboot for the changes to take effect.

I was like, cool. So I also don't reboot every few weeks, so I did updates and click restart. Then all of a sudden, all I see is a flashing _

I panicked, but I put it in another computer and the data is fine, and I used the same program to look at it again. When you have one drive, it lists it twice, One way it shows both boot sectors are A-okay, the other way it says the main sector is fine, but the backup is "Bad"

I went and used my windows disk and command line as a common solution said the use bootmanager to repair it, I did and it said it worked, then the instructions said to then do /scanos but it doesn't find an OS. Says OS Found:0

I'll edit if needed if I think of more info about what I have tried and such. Please ask as many questions needed.
I only write semi-urgent because I don't really have a backup and I need it for work. (Doesn't help that the PC beta for BlackOps3 started and only has a few days left)

Any help would be awesome.

The automatic repair thing never works.

I'd be nice to know if your disk was formated mbr or gpt so I could suggest a syntax and what version/architecture of windows you're using as well. Like Win7x64 or something.

Assuming MBR, assuming the problem is what you think it is, and assuming you can access windows re from somewhere (usb/cd/another computer) the command you need to run is:

bootrec /fixmbr
bootrec /fixboot

I have no idea what will happen if you do /fixmbr on a GPT disk. Don't try it if yours is partitioned that way. Only run the /fixboot option.

https://support.microsoft.com/en-us/kb/927392 for more info

I'm on Windows 8.1 Industry Pro x64, intel i7-870
I have used both of those commands when using the command line in the troubleshooting when using the install disc. The drive is still NTFS. I think I actually deleted the sector, not just changed to gpt or something.

Oh good, that narrows down the problem since the commands should have fixed the boot sector.

It's usually better to only have 1 drive inserted when you're recovering to avoid ambiguity so I would disconnect the second ssd card temporarily.

basic boor order: [Firmware]--[Harddrive]--[Bootmgr]--[Windows]
I think you have: [Firmware]--[Harddrive]--[Bootmgr] [Windows]
or a missing link between the bootmgr and windows, maybe because bootmgr doesn't exist? So Next up is messing with the bootmanager.

I can't really recommend any specific commands or exactly what to do without knowing the exact partition structure. To find that out run:

list disk
sel disk 0
list part
list volume

You should get something like this on gpt:

Note that the hard disk is GPT partitioned (not mbr). The system partition is Fat32 formatted and not currently mounted. So the commands to fix the bootmgr would be (optional mount the system partition first)
sel disk 0
sel part 1
assign letter=s
bcdboot c:\windows /s S: /f ALL

That's only valid for GPT tho. And assumes you don't want to re-create the partition from scratch. For MBR you need to mark the partition as active instead.
sel disk 0
sel part 1
assign letter=s
bcdboot c:\windows /s S: /f ALL

So is your drive formatted MBR or GPT and what do your partitions look like? I prefer being specific but sometimes the generalized version of the command is enough to get things to work. Can cross your fingers and try:
bcdboot c:\windows

Now are those instructions just for gpt? Because I have confirmed that the drive shoss up as mbr. And just a thought, would making it gpt help in this this case?

Sorry for small reply, just want to make sure I don't screw it up using gpt instructions on mbr.

Diskpart won't let you convert the disk from mbr to gpt with partitions still on the disk. The first example was just for gpt disks since I wasn't sure how yours was formatted. Now I know it's MBR right?

So same process with listing the disks, partitions and volumes, but with MBR but mark the partition as active as per the second example to tell the firmware/bios to boot from it. The drive letters will varry depending upon your partition layout. The idea is just to copy the boot files from the windows partition to a partition that is marked as active.
[windowsdrive]:\windows /s [boot or system partiton], so like
bcdboot C:\Windows /s S:
to explcity copy the files to the S: drive. If the partition mounted as S: is also active, then the firmware/bios will try to boot from that drive.

. /cries unmanly tears

Okay so, don't take the syntax too literally.
[windowsdrive]:\windows /s [boot or system partiton]

You only have 1 partition, so copy it from that partition to that partition.
If you mounted it as S: then
S:\Windows /s S:
If you mounted it at C:
C:\Windows /s C:

Blacks ops 3 isn't very good anyways.

But uh why didn't you just back up the data while you had it working in the 2nd computer? Just doing that and reinstalling windows is the headache free solution

Also did you buy your 128gb SD card from ebay?

@Peanut253 I'll try in a few, hang on.

@Streetguru Pc version is disappointing for now.

And I think fixithe boot partition is a problem separate from reinstalling windows.

Nope, 128GB Samsung Evo off of Amazon, confirmed not a fake. Payed $49

I wish they hadn't just copied AW and Titanfall.

Well if you already backed up your data you could try to work on it through a G-parted live USB, just gives you a GUI mainly.

Does this give you any more info?

A friend is working on it with me, we may try that.

bcdboot S:\Windows /s S:

1 Like

The command worked, and said the bot files transferred successfully, but upon booting, nothing.

Should I make a partition for the boot? Because right now there is only one partition with 350MB unallocated.

Note: One NTFS partition, 350 MB unallocated, using mbt. Just to make sure.

It doesn't really matter. MBR + active partition + boot files should have worked. If it didn't then it's not a boot files issue, the issue is something else somewhere else.

[Firmware] [Harddrive] [Bootmgr] [Windows]

Where is the problem? I'm thinking

Maybe bcdboot didn't copy the correct files or you're mixing boot modes. An architecture difference should have resulted in a blue screen not just 'nothing'.

Let's try this. Create a new Fat32 partition and create new boot files for both efi/bios systems.
sel disk 0
create part primary
format fs=fat32 quick label=System
assign letter=B
sel part 2
assign letter=W
bcdboot W:\Windows /s B: /f ALL

create part primary
format fs=fat32 quick label=System

Shouldn't I

create part primary
sel part [partition justmade]
format fs=fat32 quick label=System


Edit: Because shouldn't I select the partition just created before doing a format blindly?

It's redundant. Creating a partition automatically selects it reliably. But you're free to select it after it's already selected or check that it is or is not selected using list part.

1 Like