I need some help with my PC not starting / no display output / signal. (RX6950XT) Seemingly random timing

I know this is a very common problem and can be caused by hundreds of reasons therefore requires a lot of information to diagnose which I will get to but I’m exhausted right now. :pensive:

I rebooted my Windows 11 desktop PC and performed a TPM clear via the BIOS of my MSI B550 Tomahawk, and the next thing I know my computer no longer boots. Keyboard and mouse lights come on, fans run, but no display output.

Things I’ve tried:
-Different cables.
-Different ports.
-Powering on Monitor at right time.
-CMOS/RTC short.
-Switching from BIOS 2 to BIOS 1 on GPU.
-Switching GPU to secondary slot.
-Pulling Processor.
-Swapping Processor.
-Different 8-Pin power connector arrangements.
-Pulled RAM stick.
-Reseated RAM.
-Reseated GPU.
-Reseated M2 NVME.
-Shook tower to check for random shorts (loose screws etc.)
-Applied a little bending to motherboard to counteract too many RAM reseats. (If that makes sense.)
-Assured CPU cooler isn’t too tight or loose.

Things I’ve yet to try / cant at the moment.
-Reflash motherboard BIOS with USB drive.
-Buy new certified goat and assured quality cable for GPU / Display.
-Different display.
-Reflash GPU BIOS. (Never did it, and all I have is an unrooted android.)

I’ll love you forever if you give any form of help.

Using the troubleshooting LEDs on the motherboard, I would assume it’s a GPU (or malicious) issue. It does some weird CPU / VGA transactions and the harddrive LED is involved (NVME). For whatever that’s worth.

My 6900XT “died” after 4 years with these same symptoms. Now I’m thinking it’s not actually dying and something is corrupting / attacking my GPU but I honestly have no clue.

I recently replaced “everything”, RAM, MB, GPU.

For a brand new ASRock RX6950XT OC Edition to “stop working” slightly over a month after I bought it is extremely sus.

I will never fail to admit my 750 Watt EVGA PSU is borderline adequate, however it has no problem running this and my previous GPU at 400watts for hours of gaming so blaming the PSU has me second guessing. Unless it’s slowly damaging the GPU some how although I’m not sure how doesn’t the GPU have all sorts of safety with voltage regulators and such… I’m a little ignorant with that subject as my method of overclocking is usually “YEET”.

Been doing this for 15 years I’ve never had stuff like this happen to me ever.

Have you tried removing GPU and using the port directly off the motherboard?

I’d say try it on a tv to see if it’ll output

what code specifically does it give or is it just Leds

No, I was under the impression that is for iGPU which my 5800x3d doesnt have, but it might reset something? I’ll try it.

I’ll try an old 1080p non-“smart” tv. Just diag LEDs, I can’t really tell if it’s posting I have no speaker but it will hit the boot led then go away implying it’s posting. Absolutely zero display signal though, can’t see a thing.

I really wish android was more versatile… it’s Linux on modern hardware why can’t I find any useful tools for un-rooted phones. I should be able to reflash GPU BIOS using nothing but my phone and a USB cable to my PC… If I’m missing something please enlighten me. :pray::grin:


Ok, update. TV didn’t work, no signal. 1920X1080.

I kind of lost hope there and started messing with stuff. I have an el gato USB cam link meant for GoPro’s and such to be used as webcams.

Well I decided to try plugging in the HDMI from the RX6950XT into the el gato and then USB to my cellphone, and use some USB camera apps to try and get my PC display, with full expectations of failure, and yeah pretty much nothing. I do have snapshots of a black screen it was getting that is 1920x1080 in size, the last resolution that was plugged in… my TV.

Here’s some probably useless Info I pulled from some USB cam app. I don’t know if it’s referring to the camlink device or the GPU.

“{“venderId”:4057,“productId”:102,“serialNumber”:”[none]“,“manifuctureName”:”[unknown]“,“productName”:”[unknown] (fd9:66)",“uvcInfo”:{“bcdUVC”:“1.10”,“interfaces”:[{“type”:“videoStreaming”,“index”:1,“endpointAddress”:131,“formats”:[{“index”:1,“subType”:“59555932”,“format_subtype”:4,“format”:“UncompressedFormat”,“detail”:{“bitsPerPixel”:16,“GUID”:“5955593200001000800000aa00389b71”,“defaultFrameIndex”:1,“aspectRatioX”:0,“aspectRatioY”:0,“interlaceFlags”:0,“copyProtect”:0,“frameDescriptors”:[{“index”:1,“capabilities”:1,“width”:1920,“height”:1080,“minBitRate”:1990656000,“maxBitRate”:1990656000,“maxFrameBufferSize”:4147200,“defaultFrameInterval”:166833,“intervals”:[166833]}]}},{“index”:2,“subType”:“4E563132”,“format_subtype”:4,“format”:“UncompressedFormat”,“detail”:{“bitsPerPixel”:12,“GUID”:“4e56313200001000800000aa00389b71”,“defaultFrameIndex”:1,“aspectRatioX”:0,“aspectRatioY”:0,“interlaceFlags”:0,“copyProtect”:0,“frameDescriptors”:[{“index”:1,“capabilities”:1,“width”:1920,“height”:1080,“minBitRate”:1492992000,“maxBitRate”:1492992000,“maxFrameBufferSize”:3110400,“defaultFrameInterval”:166833,“intervals”:[166833]}]}},{“index”:3,“subType”:“49343230”,“format_subtype”:4,“format”:“UncompressedFormat”,“detail”:{“bitsPerPixel”:12,“GUID”:“4934323000001000800000aa00389b71”,“defaultFrameIndex”:1,“aspectRatioX”:0,“aspectRatioY”:0,“interlaceFlags”:0,“copyProtect”:0,“frameDescriptors”:[{“index”:1,“capabilities”:1,“width”:1920,“height”:1080,“minBitRate”:1492992000,“maxBitRate”:1492992000,“maxFrameBufferSize”:3110400,“defaultFrameInterval”:166833,“intervals”:[166833]}]}}]}]}}

{“venderId”:4057,“productId”:102,“serialNumber”:“[none]”,“manifuctureName”:“[unknown]”,“productName”:“[unknown] (fd9:66)”,“uvcInfo”:{“bcdUVC”:“1.10”,“interfaces”:[{“type”:“videoStreaming”,“index”:1,“endpointAddress”:131,“formats”:[{“index”:1,“subType”:“59555932”,“format_subtype”:4,“format”:“UncompressedFormat”,“detail”:{“bitsPerPixel”:16,“GUID”:“5955593200001000800000aa00389b71”,“defaultFrameIndex”:1,“aspectRatioX”:0,“aspectRatioY”:0,“interlaceFlags”:0,“copyProtect”:0,“frameDescriptors”:[{“index”:1,“capabilities”:1,“width”:1920,“height”:1080,“minBitRate”:1990656000,“maxBitRate”:1990656000,“maxFrameBufferSize”:4147200,“defaultFrameInterval”:166833,“intervals”:[166833]}]}},{“index”:2,“subType”:“4E563132”,“format_subtype”:4,“format”:“UncompressedFormat”,“detail”:{“bitsPerPixel”:12,“GUID”:“4e56313200001000800000aa00389b71”,“defaultFrameIndex”:1,“aspectRatioX”:0,“aspectRatioY”:0,“interlaceFlags”:0,“copyProtect”:0,“frameDescriptors”:[{“index”:1,“capabilities”:1,“width”:1920,“height”:1080,“minBitRate”:1492992000,“maxBitRate”:1492992000,“maxFrameBufferSize”:3110400,“defaultFrameInterval”:166833,“intervals”:[166833]}]}},{“index”:3,“subType”:“49343230”,“format_subtype”:4,“format”:“UncompressedFormat”,“detail”:{“bitsPerPixel”:12,“GUID”:“4934323000001000800000aa00389b71”,“defaultFrameIndex”:1,“aspectRatioX”:0,“aspectRatioY”:0,“interlaceFlags”:0,“copyProtect”:0,“frameDescriptors”:[{“index”:1,“capabilities”:1,“width”:1920,“height”:1080,“minBitRate”:1492992000,“maxBitRate”:1492992000,“maxFrameBufferSize”:3110400,“defaultFrameInterval”:166833,“intervals”:[166833]}]}}]}]}}"

I don’t think this card is broken, I suspect malicious intrusion to be honest.

Any other ideas?

Don’t suppose you have a another GPU you can pop in
Try removing everything not necessary for bios post, SATA/m.2/USB/mouse/Etherne
And any add in cards like elgato or wifi cards

Also unplug any front panel io, USB, audio from mobo

Just CPU/ram/heatsink/mobo/GPU/keyboard

Wendell’s capture card blew the other day and prevented post

I’ve also had a front panel usb short out 5v killing SATA drives

Also unplug the PC from the wall for 5 minutes, I’ve had a gigabyte board with a faulty wifi card be funny like that

If you have a spare motherboard somewhere, see if that fares you any better. It sounds like you might have a defective motherboard.

I used to have spare parts just for this reason but not anymore, besides a 3700x.

At least everything is less than 3 months old. I’ll call up the place I got the MB from, it has a 6 month store warranty luckily. They told me just bring it in if theres issues. Hopefully they’re chill enough to pop in a test card for free because I really can’t afford this.

Have you tried to disconnect it from wall power,
and then take out the bios battery for a minute?

Yeah. Tried all the normal stuff that I can think of. I’ll probably take it to a shop to try a different video card. It’s so annoying not having spares.:smiling_face_with_tear:

Well well well… winner winner chicken dinner.

I put some parts together (Q6600/DDR2/PCIE2.0)

Slapped the RX6950XT on it. Worked immediately.

2023 meet 2007.

So, problems with the motherboard… well at least from what I can gather. The GPU could potentially have Infected UEFI firmware that doesn’t work on a 2007 era PC right?


the psu you used to power this on the 6600 system and get it running…
can you plug it into the faulty new system?
and get it running with an old low power gpu?.
if so do so…
then power it on and see if you boots with the 6950.

sure it could be the pci-e slot on the motherboard.
but removing the old psu that may be aging out could also be the fix it…

my reasoning…
new gpu’s have finer power requirements which can cause short lived peak load spikes in the psu.
if the peak load is repeated, this can overwhelm the self protection systems of the psu and cause a shut down in a good scenario, in a bad it can degrade the power rails till the system fails to boot.
so basically if your psu cant switch quick enough it falls over.

testing with the spare build 6600 psu…
do not stress tests the 6950 in your new build its just a power on will it boot test for the system.
if it does boot then you probably need a new psu that meets newer standards. rather than a new motherboard.

I only have 1 psu. EVGA 700. I thought it was a 750 but I just learned that today.

Ive been gaming with this thing on a 6900XT for 3 or 4 years at 400 watts load. The 6950XT was a replacement card, been gaming on that for almost 2 months until the last few days. I wouldn’t doubt the 700watt PSU is on its last leg though, it’s been running 400 watt GPUS for almost 5 years now.

For it to immediately start working on a board from 2009 and not work on my 3 month old b550 tomahawk, that tells me there’s a UEFI infection or the motherboard just up and died. This failure happened immediately from a single TPM clearing in the BIOS. Coincidence? No clue. The motherboard also doesn’t flash bios properly using the USB port in the back. I’m not new to doing that either, that’s how I updated my old Asus ROG b550.

I’m taking the MSI motherboard to the shop I bought it at and having him see if it works on his stuff. The easiest thing to do and it’ll tell me the most information.

fair play… i thought you were testing with an alt psu aswell.
tbh now you explained it that way, yeah… sounds like the board has an issue…

Your PC isn’t FDE with bitlocker is it?

try the old school method of clearing the cmos .
pull the plug from the wall.
pull the battery out the motherboard.
plug the pc back in. hit the switch on the back of the psu. so you see the motherboard led’s flash.
turn off the power at the switch and quickly short the +/- battery terminals. you will have a couple of seconds of residual current to do this… so short the terminals for 1-2 seconds.

replace the battery and try rebooting.

if it boots to eufi. clear all your keys to factory.
and then turn tmp back on.
and hope win 11 boots.

if you installed win 11 with tpm on it wont allow you to boot the system if you turn it off after install.
so yeah turn it back on and hope windows re-writes the tpm hash.

1 Like


I have my gaming monitor using DP and an old 1080p TV using HDMI as dual monitors to see if anything works. No signal anywhere.

Here, take a look at this 2009 piece of sheer superiority in all it’s glory. The board that got me a RX6950XT signal, while this brand new MSI can’t wipe it’s own ass.

This thing ran Sub-Zero temps using water and methanol over 10 years ago, bulging capacitors and all and this thing is still better. WOW.

honestly mate i dunno whether to laugh or scream at them pix…


Either is fine with me. It’s dielectric grease btw, lol.

Here’s my depression zone.

I wish this proved something but it doesn’t lol.

I hate not knowing what the problem is…

If it screwed up both my 3700x and 5800x3d AND MB you’ll find me crying in a corner for a month fam. Was nice knowing ya.

Ok, took the motherboard back to the shop and the PCI Express slots are bad. All of them.(MSI B550 TOMAHAWK)

iGPU works.

Why in the HELL would that happen after a TPM clear…