I need help. Corrupted HDD

Long time ago i tried to encrypt my WD 1TB with Diskcryptor the program was at 90% but for no reason my pc turn off.So i open again and i couldn't enter to the OS the hdd and i couldn't do anything.Now i took 30gb hdd from an old ps3 :P and i run linux and i use enclosure hdd to my 1TB..I tried to format it but nothing i get error and the pc cant read it or mount it .I dont care if i loose any data from drive can anyone help me?.Its 1TB drive i dont want to say goodbye xD

In an elevated command shell run these commands

list disk
select disk (#) (replace # with the number that the corrupted drive reports as)
create primary partition
format fs=ntfs

Im using ubuntu-gnome now.

Have you tried formatting it in G-Parted?

I cant.the program give me errors.

Can you use a terminal-based partitioning program like parted or fdisk?

i cant find it with fdisk i will try with parted.

can you help me a little bit with the parted? i use it first time.

Well, if you know your device name, you can use parted /dev/sdX to edit the drive's partition setup. You can use the 'rm' command to remove partitions and the 'help' command to see all the commands.

i wrote parted /dev/sdb and then rm and the terminal give me this:

Error: /dev/sdb: unrecognised disk label

Is that all the output it gives?

Also, can you show the output of lsblk?

sda 8:0 0 37,3G 0 disk
├─sda1 8:1 0 512M 0 part /boot/efi
├─sda2 8:2 0 30,9G 0 part /
└─sda3 8:3 0 5,9G 0 part [SWAP]
sdb 8:16 0 931,5G 0 disk
sr0 11:0 1 1024M 0 rom

Sorry, man, I'm not sure if I can help... Most everything I can find that's Linux-based has to do with file systems, and your hard drive seems seem to be corrupted to the point that the partition doesn't even show up anymore. Unless someone else has a possible solution, I think it may be bricked. :/

There's a video Windell made about RAID corruption that may help.

Can diskcryptor read the drive? Do you have a computer laying around with Windows which you could use to try it?

The encryption didn't complete so i'm not sure if the program could read it.

Note: Names of utilities aren't 100% accurate, just going off memory here.

Download https://partedmagic.com/ and burn to a cd or make bootable flash drive
go into the bios enable hotswap for the sata port/s
disconect sata data cable but leave the power cable in
boot parted magic
plug in the data cable while pc is on
open the disk health utility and check the smart data
If anything is red except for "Current Pending Sector Count", the drive maybe beyond help.
open the disk erasing utility
select internal secure erase
once complete try creating the partition table and format, if it doesn't work try doing it though windows (may work from the install disk)

Sounds like your partition label may be unrecognized or broken.

Go into parted again and try:
mklabel gpt
Optionally create a partition that spans the disk:
mkpart primary 1 -1
Exit with

error input / output during read on /dev/sdb

Input/ouput error may mean hardware issues.

Does you see any /dev/sdb errors if you run dmesg?