Return to

I can't get OBS working in openSUSE


Here is video to show the problem I am having.


@Tex Have you tried using the Packman repository in openSUSE? Supposedly OBS from there works better, but alas, I have not tried it. I'll see what happens on my system here and report back if I get the same error as you.

EDIT: I was able to fix the problem by installing ffmpeg from Packman's repository, so why don't we try that for you and go from there?


I didn't know that you could even use pacman on opensuse. I will try this when I get home in a few hours.


If you've got an nvidia gpu (kepler or newer) don't forget to rebuild ffmpeg to support nvenc.
How to for ubuntu shouldn't be too hard to rework for opensuse.


I( have the amd rx 480 so that isn't a problem for me. Thanks though


ah, yeah, you need a slightly tweaked build of ffmpeg, the version of ffmpeg you have doesn't support aac encoding it seems.

install the source package for libfdk-aac and then rebuild ffmpeg with --enable-libfdk-aac --enable-nonfree added to the buildconfig.

or maybe theres a ffmpeg nonfree variant in the repos?


Thanks it seems to work now, installing VLC to make sure I can play the vid though.


@Tex Great to hear man! Also, with the Packman, it's not the same thing as in Arch, it's a specific Repository that allows you to have some different version of the software for openSUSE. Hopefully everything continues to work for you though, any more questions just shoot 'em our way!


a note about VLC, they have specific instructions for installing on OpenSUSE. They have their own repo, so it might not be the best to test with.


@Dynamic_Gravity Interesting... I was told to use the Packman repo, but maybe I missed the exact instructions from the VLC web page.

EDIT: Well look at that, forgive me, I'm ridiculously tired....


I just tried to get VLC last week when I switched to Tumbleweed. Packman repo doesn't work for VLC only their instructions on their site worked.

Furthermore, once the repo is added a sudo zypper dup is needed, and some packages will shift control over to the VLC repo.


I used yast and it works fine.