I can't connect to wifi network using my usb wifi adapter Ubuntu

I can't connect to wifi network using my usb wifi adapter. My adapter is the Tp-link Archer-T2U and my os is ubuntu 14.04 gnome 3. I have tried:
-Doing a full system update.
-Going to additional drivers (doesn't show up)
-I tried using a program on the ubuntu software centre called "Windows Wireless Drivers" when I installed it I couldn't find the application on my computer.

Theres not currently a working driver for this chipset. https://wikidevi.com/wiki/TP-LINK_Archer_T2U

Do you need AC?

Your best bet is to buy supported hardware. These should be supported, and all use the 8812au driver (source)

Edimax AC1200 EW-7822UAC
Linksys WUSB6300
Rosewill AC1200UBE
D-Link DWA-182 H/W VER.:C1

You can also use the wikidev site to look for supported cards. The gentoo wiki has instructions on how to search for them

Browse to https://wikidevi.com/wiki/Special:RunQuery/Wireless_adapter_query .
Find "Supported 802dot11 protocols:", enter abgn+ac .
Find "Table query type:", select linux_support .
Click "Run query" .
Scroll down to find a table of known abgn+ac Wireless Adapters with chipset, pciid, and possible linux driver. The AC1200 adapters in the table will have RTL8812AU or BCM43526 chipsets. The other chipsets listed support other protocols.

@Eden if I get the D-Link DWA-182 H/W VER.:C1 I will have the necessary drivers to get my wifi connection working on linux?

Do you have an internet connection through ethernet or otherwise? The 8812au drivers still need to be manually installed it seems (for whatever reason), and would need to me remade acording to the instruction every kernel update.

So youd have to install the drivers following the answer in this post: http://askubuntu.com/questions/491263/installing-rtl8812au-linux-v4-2-0-6952-20130315-tar-gz

The ALFA Network AWUS036AC is also supported in that driver.

It should work, but ive no way of testing so i cant guarantee it.

The other main chipset and driver that is apparently supported is MT7610U chipet and mt7650u sta driver.