Return to Level1Techs.com

Hyper-v start-up times with ryzen 3000 b450

Has anyone noticed slow start-up times on a windows host? At startup I am eventually greeted cheerfully by a spinning circle on a black screen that does little but mock me for a couple of minutes. Eventually the system deigns to grace me with its presence however.
This is only while hyper-v is enabled and irrespective of whether SVM is enabled in BIOS or not. (So no hyper-v + SVM: ON -> “fast” boot, hyper-v enabled and SVM: ON -> gleefully mocking spinning circle of doom) .
100% reproducable even across different windows (re-)installs and graphics drivers, leading me to believe this could be ryzen related? Clean booting does nothing. Safe booting does fix it, but I assume it simply circumvents hyper-v?

I guess my question is: is this a known issue (I cannot find it) and if it is not, do you think changing my motherboard might improve things?
Say from b450 carbon ac to x470 taichi?
Help and mockery very much appreciated

Cheers,

EDIT:

I have now done the following:
unplugged every device except mouse and keyboard. This includes all storage devices except one, as well as my sound card and my second monitor.
Current Setup:

  • Ryzen 3700x
  • b450 pro carbon ac
  • 32GB Crucial Ballistix Sport LT V2 Dual Rank grau DDR4-3000 DIMM CL15 () (BLS2K16G4D30AESB)
  • PSU
  • a hd 6870 GPU

now the GPU is simply to rule out my main GPU as a source of trouble, which is a GTX 670. With this setup, I should be able to rule out NVIDIA or AMD drivers.

Bios settings:
IOMMU “Enabled”
SVM Mode “Enabled”

(probably not of interest but in the same sub-menu:
Global C-State Control “Auto”
Cool ‘n’ Queit “Auto”
P-State Adjustment “PState 01”
PSU Idle Control “Auto”
)

With this modified barebones setup I reinstalled Windows from scratch again, deleting all files on the last remaining SSD (Samsung),
updated through the Windows check update function and rebooted a couple of times to check start-up times, which seem fine. I then activated the Hyper-V functionality and the problem appears again.
(long black screen with a spinning circle before login screen but after post, obviously)

So for posterity and to save someone else the trouble:

The problem must either be windows, ryzen 3000 or b450 dependant.

timpelplomp

2 Likes

That is an interesting issue. Your UEFI/bios is updated correct?

Hi,
yeah I flashed the Bios to the version 7B85v17 for ryzen 3000 support, which is the most current one listed by MSI for the B450 gaming pro carbon ac.

That is weird dude. @wendell have you tried Ryzen 3 on b450 with hyper-v on?

I just thought of an edit, concerning safeboot, which I’ve included in the original post. (I do not know if you get an edit notification so I thought I would mention it seperately)

1 Like

Set iommu to on not auto. No svm and windows uses a different scheduler

IOMMU and SVM are enabled on the most recent runs; I’ve included this information in the original post as well as the other bios setting under the same submenu.

Made an account just to say I’m having exactly the same problem with a 3900x on and x470 board. Glad it’s not just me.

I’m wondering if it’s related to the bug in the current AGESA bios with random number generation, that’s known for breaking systemd on Linux and Destiny 2, but who knows what else it’s affecting.

2 Likes

Tried with IOMMU on/off/auto no difference.

SVM needs to be on or hyper-v does not function. I did try it off and the boot up was fast but the hypervisor / VM didn’t start.

2 Likes

Always good to find a fellow sufferer. What’s the motherboard you are running?

1 Like

Asus CROSSHAIR VII HERO latest 2501 bios, which is still based on AGESA 1.0.0.3 (not AB) apparently ABA will fix the Linux crashing so waiting patiently for that.

1 Like

Same issue here. ROG CROSSHAIR VI HERO with Bios Version 7201 running on Windows Server 2019.

Also, not sure if it’s related but I’ve also had several other issues since switching cpu’s like one random BSOD in the middle of the night while the machine was pretty much idle and multiple VM’s showing issues they’ve never shown before.

Shucks,
for what it’s worth: I have not had any random BSODs yet. I’ve also not really started migrating my VMs yet though, due to the current problem.

Hey, I’m having the same issue with my new Ryzen 5 3600 on a MSI Krait Gaming X370. Dunno if it’s CPU - BIOS - driver related at this point… Suspecting BIOS cause it’s in beta state ofc. Still the same BIOS worked fine with my Ryzen 5 1600X. SVM Mode works, but it’s just long boot times that is annoying :grimacing:

Not sure when or what fixed this, probably the new AMD chipset driver, but my boot time is normal now. No black screen.

I too am having this problem. I wish i knew this was a problem. I just got done doing a fresh install. The moment i enabled hyper -v and wsl, the slow boot started again. I uninstalled both, and restarted the pc a couple of times, and fast boot resumed.

SO I guess the culprit here is Hyper-V. Unfortunately WPA/WPR does not help.

I also created account only for this topic. I have the same issue on AMD Ryzen 3700X and MSI x570 Carbon Pro WiFi

I enabled SVM in BIOS and Windows worked correctly. Also VirtualBox was able to launch VM. Unfortunately I wanted to run Android Emulator. For AMD processors it requires enabled Hyper-V.

I enabled Hyper-V and now Windows boots couple minutes. Android Emulator works (however I have problems with snapshots), but Virtualbox stopped working - maybe I miss something in config.

My main concern is long booting time. MSI didn’t publish any new BIOS. Did you manage to resolve this issue somehow?

MSI said they were going to publish a new BIOS for this issue. Still waiting.