HPE Kioxia U.3 to PCIe on Windows Help?

Hey Guys,

I recently purchased two unused CM6-R 15.36TB HPE/Kioxia NVMe SSDs for a sweet price on Ebay, but I’m having trouble with Windows 11/10 reading the drives correctly on 3 separate systems. I stupidly purchased a U.2 to PCIe adaptor so I thought purchasing an SFF-TA-1001 SFF-8639 (68 Pin female) interface slot for a 2.5-in U.3 would fix this but no dice here either.

Here’s My Specs (My Main Rig):
Ryzen 5900x
Aorus Master x570s Motherboard
1TB 980 Pro (Boot Drive)
RTX 3070
Windows 11

So here’s what is happening…
I installed the drives in the carrier/adaptor card and connected to Gen 3/4 compatible PCIe slots. I boot up Windows 11 without any issues. I check drive management and I’m prompted to initialize the disk (GPT or MBR). I choose GPT and the drive is not assigned to any drive letter and it doesn’t show any partitions for me to manage. When I check the device properties it states that, “Device Was Not Migrated Due to Partial or Ambiguous Match”. The drive shows up in Crystal Disk with some insane amount of storage capacity, but the drive looks fine (no usage, no writes, etc.). I can see the drive capacity reported accurately within different SSD managers like Samsung, Intel, WD, but I can’t seem to get either drives working.

My theory is either there is an issue with the Carrier/Adaptor Cards or an issue with the Driver. I checked the driver and it seems to be defaulting to a Microsoft Driver of some kind and when I check the date on the driver it says it’s dated 2006. I’m wondering if these drives are not compatible with Windows? Would testing on Windows Server or Linux solve this issue. I would rather avoid changing the OS, but I can’t seem to find the solution here. Does Kioxia have a special driver for CM6-R drives or…?


Okay, so I figured it out somehow… For some reason either Windows isn’t good with certain LBAF numbers or there’s some weirdness with the drivers or U.3?

Here’s what I did:
I grudgingly grabbed an Ubuntu Live USB and installed nvme cli through terminal. Then using “sudo -s” I grabbed some information on the drive using “nvme list” took note of the drive address that I wanted, and formatted the drive using: “nvme format /dev/(Insert Drive) -l=0” and then created a partition within Ubuntu to NTFS for Windows. I don’t know which part of that process fixed it, but the drive is now recognized in all its glory within Windows 11… I’m going to bed now

1 Like

Thankyou so much for posting your solution, I had exactly the same issue.

No problem. I spent 7 hours trying to figure this out. I’m guessing it was the LBA scheme that the drives are using. The drives are defaulted to 1 which is stil 512, but setting to 0 seems to fix the issue. I’m sure you could even skip including the l=0 since NVMe CLI just defaults to the current scheme you are using. Such a weird issue with Windows. Then again… these drives are made for enterprise/linux environments.