HP Z420 Disk Errors on Ubuntu Server 20.04.1

Basically my Z420 server has disk I/O errors all the time. What happens is it just floods the server with errors and gets worse after more time(I’ve reformatted it multiple times and done fresh installs that many times also). I also replaced the SSD and Motherboard, so it shouldn’t have any more problems. It makes it unusable. It only happens after a day or so and gets worse over time. I’m wondering if I need a new different OS or something else with hardware.

Thanks for your time,

Also I had just a single SSD and now I have two new SSDs in raid 1. I also tried different SATA cables.

Sounds frustrating!

Replaced board, drive, cables … run a memory test maybe?

Put the drives in another machine and run badblocks on them, just to confirm the drives are healthy.

Post up a copy+paste of the errors you are receiving?

Will do when I get home! Thanks for the quick response!

I ran badblocks on them a while ago when I noticed the first time. It was inconclusive. But I did the memory test and nothing was wrong. I’m still super confused but I’ll try badblocks again.

I did badblocks again and and it said no errors. And BTW can’t copy paste the error messages because it just spams it so I can’t type anything. Unless you want me to take a picture/video of it.