HP 530T Dual 10GBe NIC strange behavior

Hey all,

I’ve just picked up a couple of HP 530T Dual 10GBe (BCM957810A1008G) cards and I’m having trouble getting them to run on my intended platform.

System I’m putting one into is an i5 4570 on a Gigabyte GA-B85M-D3H.

If I plug in the card and power up, I get 4 long blinks of the HDD LED and then nothing. Removing the card allows the machine to boot.

This is where the weirdness comes in. If I boot the machine to BIOS and then hotplug the card it works fine. A soft reset (Ctrl+Alt+Delete) allows me to get into the QLogic firmware configurator and all seems good from there on, until I power cycle or hard reset from the BIOS.

Anyone have any clue what might be wrong or where I can start looking to get this running?

How long are you waiting for the system to boot? I also have a dell 530 based dualport 10gb nic in my x570, takes about 60 seconds for the system to boot with it. I also have CSM disabled, UEFI mode only. Make sure CSM settting is appropriate for the card, boot times are long as far as I have read in forums.

Way longer than 60s - longest I’ve left it at this point is about 30 min when I got busy with something else…

CSM appears to be disabled (at least the option disappears with “Windows 8 Features” set to Other OS), but let me give it a go with UEFI only boot mode and option rom and see.

No dice, same result regardless of CSM & UEFI mode.

Also tried disabling VT-d in the BIOS and SR-IOV in the rom config with no change :frowning:

Hmm, sorry I cannot be of any further input going forward. How much research did you put into this card before purchase? Was it recommended or did it have a good price/needs and ticked those boxes? My experience with hp enterprise is spotty, one example is the HP Turbo G2 nvme adapter for workstation Z420 and higher.

This unit as an example: 742006-002 HP PCA PCI-E TO M.2 HIGH PROFILE ADAPTER BOARD MS-4365 721541374046 | eBay At the time needed 4 units and I snagged a deal on ebay for $5 a pop and was giddy. Until I installed into non-OEM motherboard (Asrock/gigabyte/supermicro et al) and it did not function, whilst the Uefi supported nvme detection and bootability; JUST not with that HP adapter. After purchasing I lucked into this thread at STH Need help with HP Z Turbo Drive G2 512GB. | ServeTheHome Forums and read more into it and learned there are specific hardware blocks that inhibit use in other manufacturers system (essentially had to deSolder tiny capacitors on specific area to enable it to work) Sometimes it is not as starightforward as it appears. Good luck, do you have another motherboard to test with?

Yeah, I hear you.

Didn’t do much research apart from chipset & controller support OS side, but the price was right.

They both work fine in my main system (Asrock TRX40 Taichi & 3960X) so I don’t think vendor lock is an issue. I’d expect it to fail if hotswapped as well if firmware lockout was causing it?

As far as I can tell there’s no physical differences between the Dell, Lenovo and HPE versions of these cards. I’ve read in a couple of places stories about peeps flashing them to the HP firmware to resolve an issue with link drops, but haven’t been able to track down the tools & images.

Managed to figure this out with some digging and a lucky guess.

I think the root cause is a buggy SMBus implementation on this motherboard. Taping over pins 5 & 6 on the card with some kapton allows the machine to boot.

There’s a writeup at Yannick’s Tech Blog about some LSI RAID cards needing the same thing.

Incidentally, boot time is comparable (read less difference than I can time counting Mississippis) with and without the card installed when in UEFI mode, and works with CSM on or off, Legacy or UEFI modes.
I haven’t tested network boot, but I can see PXE initialising when it’s enabled so I have no reason to believe it wouldn’t work.

2 Likes