How to prevent gnome-keyring from asking for a login password?

I have autologin setup, (only I have access to the computer physically) and need to put a password in for gnome keyring every time I first launch chrome. I tried changing the default keyring to the login keyring, in an attempt to launch chrome without a password. But, now that I’ve switched the default keyring back to the default keyring from the login keyring I’m getting a password prompt for the login keyring everytime I log on.

Previously, I never had to input my login password, while it still had a password attached to it. How may I revert to the old behaviour without disabling the password entirely on the login keyring?

Your keys are stored encrypted so GNOME needs a password to decrypt them. Since you had a login password active before GNOME could decrypt your keys when you logged in and never had to ask you. But because you have disabled password login GNOME cannot decrypt them automatically anymore. Hence it asks you when you first try to access it.

Your options are:

  • get asked for your password
  • store your keys unencrypted (I don’t know whether the keyring supports this, Google is your friend)

GNOME doesn’t have mind reading technology built-in yet

1 Like

How would I reset it to the previous behavior of only needing the default keyring password? I’ve had autologin set up for a long time, and have never had gnome keyring ask for the login password before.

I don’t think we are on the same page. This reads to me like you did use a login password?

You cannot encrypt data without a password. I’ve also never seen a GNOME keyring that behaves like what you are asking for.

The root and user accounts each have a password connected to them. Trying a few work arounds for getting pam to unlock the keyring caused gnome-keyring to ask for the default and login keyring, after lightdm logs me in through pam. Previously, I only had to input the default keyring when launching Chrome. Now, I’m getting asked to input the login keyring everytime I log in.