How to get xbox 360 wireless controller working in linux

hey ive got a xbox 360 wireless controller with the wire that you use to charge the battery pack inside it but i dont know how to set it up to get it working if you know pls help im trying to get endless sky working with it witch would be nice


Is that the play and charge kit? I'm pretty sure that doesn't allow you to use the controller even on Windows. I've tried it before and it didn't work. You have to have the USB wireless receiver dongle basically. Not sure if that works in Linux though but probably.

Are you playing only Steam games?
If so just plug in your wireless dongle to USB start up steam and turn on your controller, it will just work.

For games outside of steam I recommend using xboxdrv (any distro)
or if you are in Ubuntu get ubuntu-xboxdrv with these comands:
$ sudo apt-add-repository ppa:rael-gc/ubuntu-xboxdrv
$ sudo apt-get update && sudo apt-get install ubuntu-xboxdrv

You need the drivers for it . I have a link to them saved however I am not near my laptop to post the link. For some dumb ass reason that major Nelson guy severed the hyperlink from his post but you can still get them .

Here is a site.which has gihub links and repasitory

I use an application called QTSixa. Works wired or wireless
It also forces the controller to work. I have tried all sorts and all of them worked.

nothing worked unfortunately :*( well cheers for the help guys

I don't know why they didn't make the play and charge work like a USB device and just make it a wired controller, but I can assure that that is your issue since it doesn't work in Windows either last I tried.

There is no reason it shouldn't have worked out of the box. I have a logitech rumblepad that linux forces to the xbox standard. @ninja85a what is your distro & release number?

If it is a plug and charge kit only then it will not work apparently that cord only provides power and does not provide the data lines necessary to make the controller function, I tried the exact same thing and spent many hours cruising forums until i figured this out.

im using ubuntu gnome 15.10 with the 4.3 linux kernel

Yeah, play and charge doesn't work with any OS on PC, sorry man.

You need a wired controller to work. I currently have a Gamestop wired controller.

LiveCD into gnome 14.04 and see if it works there?