How to get atom able to build and debug C++ files?

ive tried that but when ive installed gcc using pacman -S gcc it doesnt put any files in the bin folder any idea?

Works for me. It was within /usr/bin/g++.exe, where the top level directory was my MSYS2 installation directory.

just checked there and its there but atom still doesnt pick it up
well the package doesnt

Have you tried putting the full path to g++.exe?

yup that worked its got this error on the bottom is this norrmal or not?
C:/msys64/usr/lib/gcc/x86_64-pc-msys/6.3.0/cc1plus.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

Might be that you aren't including local files, add -./ to your include paths in the linter config.

i cant seem to find that in the linter config
nvm found it

still not finding it and ive checked in the folder it was looking in what its looking for isnt there

You're still not finding what exactly?

well apparently cc1plus.exe isnt there but it is?

You need to completely describe your problem rather than giving fragments of information if you actually want help. Screenshots, error messages, details.