How to disable turbo-boost

Does anyone know how to disable Intel's turbo-boost?  Core i7-2630QM.

why would you want to? anyways, it's a setting in the BIOS, probably under advanced

My laptop heats up too much, but thanks I will take a look.

that shouldn't be caused by turbo-boost... it adjusts based on thermal headroom. clean all the dust out of it

It's a mobile cpu.... Fanspeed/heat would probably be the main reason.

... I know that... i'm kinda on a laptop right now... turbo boost adjusts you cpu's clock bases on thermal headroom and load

Go to power options in control panel. Click advanced. Then go to processor power management. Here you can adjust the maximum processor state on battery and plugged in. Also make sure the minimum is not higher than the maximum. That should help.