How to correctly install Nvidia Drivers on Ubuntu 18.04?

How do you install the Nvidia drivers on Ubuntu 18.04 correctly?
I have tried the automatic method through the Software manager. I have also tried them through DKMS with the nvidia package I downloaded from
I have tried several methods and they all bork the system after reboot.
I got it installed on Fedora 28 through DKMS but the same instructions dont appear to work on Ubuntu.

I am pulling out my hair as I have blown several hours fighting with this pile of waste called Nvidia drivers.

Any assistance would be greatly appreciated. I swear, I never had this much trouble with AMD drivers.

I’ve not used Ubuntu on an Nvidia rig in a long time. But I always

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update && sudo apt upgrade -y
sudo apt install nvidia-3xx -y (xx being the numbers, probably 394 in your case).

This USED to work, but I have not had success in quite sometime on my battlestation with Ubuntu. I’m pretty sure this is because of my motherboard, because other systems that have often yielded complaints with UEFI and/or Nvidia don’t work (Manjaro, Antergos, Solus, etc.)

There was a video floating around that showed how to do all of this manually, but I never tried it… Some nasty fellow. Brb

Maybe that’ll help? I watched it a long time ago at the recommendation of a friend. Be aware he appears to masturbate and does some gross noises throughout the video from what I recall.

I think based on my experience with Installing them on Fedora 28 that I first need to install kernel 4.16.x

Yeah, start with 384.111 if you’re on an older kernel, then install 390.48 if you get a newer kernel. If you upgraded Ubuntu, there likely are backup kernels of older versions you might be able to boot from.

The Graphics Drivers PPA is the better option, but make sure to install nvidia-drivers-390 and not nvidia-390 alone.

I installed the driver using System76-driver-nvidia.
It “works” but I have to add nomodeset to GRUB.

There HAS to be a better way because this is nuts.

There’s no getting around the need to disable nouveau. You have to disable nouveau and do a update-initramfs

what does disabling nouveau do? Will it stop the nomodeset need? I thought that was because the driver is not signed

On Fedora your best method is the negativo17 repo, then the rpmfusion repo (in my preference, negativo17 has a dkms version which i think works better). I wouldn’t do it any other way.

(not much help on Ubuntu, but just as you mentioned it)

Negativo17 doesn’t make it easy. I’ve had to do voodoo to get the driver installed. Had to install the kernel headers which involves typing in the entire package name to install it or removing the package and reinstalling it in order for dkms or akmod to see the headers… Nvidia, FUCK YOU!!!

You should need kernel-headers and nvidia-dkms, that’s about it unless you need any fancy stuff. And if you really wanted to you could do it via the GUI once the report is added. It’s definitely the better option than the manual install. I agree though that it’s still a pain, but that’s the nature or proprietary drivers.

no you see, I had to uninstall all the needed packages. THEN reinstall them just for the DKMS Autoinstall to work. Otherwise it would claim I was missing headers and such no matter how many times I installed them. And it kept installing driver 390.18 or something. The current drive is 396.24. I got it installed painlessly under Antergos Arch Linux.