Return to Level1Techs.com

How to change audio source in linux (KDE Plasma)?

yes i know this widget but it doesn’t show the front panel connection. also there is no option to adjust left and right balance for speakers. when i used windows 10 i used the to switch outputs. maybe im missing something here are the screenshots of my volume control


my headphones are connected right now on the front audio. but no option to switch source. and no option to adjust left right balance

Under “Devices”, on the “Built-in Audio” device, do you have a “Port” drop down menu? Does it have 2 options. That let’s you set the volume but tells you if pulseaudio is even aware of both ports.

this you mean?

i dont see any option for front audio

No, not under advanced. Under Devices:

i posted this exact post on destination linux forum, i have already tried what u said, and it didn’t work

my post on destination linux - https://discourse.destinationlinux.network/t/how-to-change-audio-source-in-linux-kde-plasma/1829/9

Have you looked at what is happening in alsa when you switch from Line to Headphone in Pulse? Using alsamixer and Audio Volume Settings, here is what I found:

Headphones (audio through headphones)

Line Out (no audio)

Playing around I found I could get audio out of the speakers if I disable “auto-mute” while “Line Out” is selected in Pulse:

Line Out (audio through speakers)

This is with Fedora 31 and ALC1220. But looks like Pulse just needs to disable the auto-mute when switched to “Line Out” and re-enable it (or some equivalent) when “Headphones” is selected.

Based on that I think this section from the Arch wiki might be relevant. Unfortunately my setup in Fedora 31 does not match, so it is going to take some reading up on my part to figure out how to apply that logic to my setup. Might have some more time to investigate tomorrow.

i have this exact post posted on destination linux’s forum - https://discourse.destinationlinux.network/t/how-to-change-audio-source-in-linux-kde-plasma/1829/15

while switching from speakers to headphones in pavucontrol-qt as i was getting audio from both speakers and headphones at the same time by doing that so i took a look and noticed something (i deleted the sinks i created before in /etc//pulse/default.pa)

when im using default line out output (on the left in pavucontrol-qt) im getting audio from speakers marked with orange the front in alsamixer controls the volume of rear jack which is called line out in both pavucontrol-qt and kde volume manager which the alsa mixer has a line control if u look at alsamixer 4th from the right (the headphones volume in alsa is at max right now but i dont get any sound)

but when i change to headphones (on the left in pavucontrol-qt) im getting audio in headphones (marked green) and speakers (marked orange) same time but if i lower the volume of front in alsamixer (marked orange) i get audio in only headphones which is the front panel audio jack

if u can join me there we can talk there its hard to talk same thing over 2 different forums

well according to archwiki i ran “pacmd list-sinks” command and got this output there were 2 sinks 1 was the GPU HDMI output which is not useful here the other one is -->

        name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
        driver: <module-alsa-card.c>
        flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 9039
        volume: front-left: 15823 /  24% / -37.03 dB,   front-right: 15823 /  24% / -37.03 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 1
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
        card: 1 <alsa_card.pci-0000_00_1f.3>
        module: 7
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC892 Analog"
                alsa.id = "ALC892 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xdf220000 irq 127"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "a170"
                device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Realtek ALC892"
                alsa.components = "HDA:10ec0892,1462f972,00100302"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
                        properties:

                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
        active port: <analog-output-lineout>

then according to wiki i added these lines in “/etc/pulse/default.pa”

load-module module-remap-sink sink_name=speakers sink_properties="device.description='Speakers'" remix=no master=alsa_output.pci-0000_00_1f.3.analog-stereo channels=2 master_channel_map=front-left,front-right channel_map=front-left,front-right

load-module module-remap-sink sink_name=headphones sink_properties="device.description='Headphones'" remix=no master=alsa_output.pci-0000_00_1f.3.analog-stereo channels=2 master_channel_map=rear-left,rear-right channel_map=front-left,front-right

then i got 2 sinks in the system tray widget after logging out and logging back in but none of those 2 sinks give any output nor speakers neither headphones

i recently added this thread to r/kde (Reddit) page. i posted this there no help so far. still looking for a solution.

wow absolutely no help, i have this thread 5 different places everywhere people stopped responding after a while no one asks me for some info or terminal output that i show or try to fix this. :confused:

It normaly change automativly but when I see that corractly your default device is the HDMI Output

in of the screenshots yes its showing default as HDMI but i have already tried switching default to headphones still wont work

Is the fron port of the case realy connected on the Moutherboard?

yes i dual boot windows for a couple of games and i use it in windows too.

Ok for trubelshoting try anouther distro that also runs with KDE Plasma(maybe one withe the same version and one with an newer version).

i have already tried it, doesn’t work. i have tried ubuntu and manjaro.

So I am thinking this is a hardware issue more than a software issue since you also have the issue with Ubuntu and Manjaro. The Realtek ALC892 is a pretty common chipset so I would find it odd that there would be major bugs like this considering how commonly used it is and the age of the chipset. Also although I didn’t have a KDE distro on a flash drive on hand I was able to test with Pop!_OS on a system that had a 892 chipset and it did detect when I plugged/unplugged headphones. Now I am assuming you were running standard Ubuntu and not Kubuntu meaning you also had the issue on Gnome if not then well I will test with a KDE distro when I get a chance.

Would be nice to know what headphones you are trying to use I’ve had issues on both Windows and Linux over the years recognizing headphones that had in-line microphones. Windows has improved on this over the years I believe so that could possibly be why it works on Windows, but it’s been awhile since I last used headphones that had an in-line mic so can’t say for sure. You could also just bypass the chipset by using a USB DAC instead.

you talking about the front panel ?
im using using arch linux with kde plasma as desktop, and when i said i tried on ubuntu and manjaro i did not installed them i just tested it while booting the live usb, and the headphones are basic standard headphones (HP branded) with 2 separate 3.5mm jacks for headphones and mic and a usb cable that is just for the led lights its does not do anything else. and in windows i have to go to the realtek audio manager software that came with the motherboard and turn off the front panel port for some reason then it detects, and shows a separate audio source in the taskbar as realtek 2nd audio output.

this is a old thread for windows 7 but its the same what i do windows10 has option to change output in the taskbar volume icon if u click on it you get different output options-
https://support.rm.com/TechnicalArticle.asp?cref=TEC1549541

Yes I was talking about the front panel, but just to make sure I understand it correctly you still had this issue when you did the live usb right?

As for what you have in Windows that is normally what it would read if you have allowed it to treat the front panel as a separate audio output (at least in my experience anyway). As in you could have a different audio stream going to your rear port than your front panel port. Used to do this with my old setup would have game audio/music going to my rear port and then Discord going through the front panel port. Not a 100% sure why it shows up that way when you disable the front panel header in the Realtek driver though

yes i had this issue even when using live usb.

yes i need some way to switch between the two so while playing games i dont have to unplug the speakers from rear and plug headphones there. i do same in windows i use front panel when playing games

Speakurs is yoir rear port, headphones is the front.

Open pulseaudio and hit the green checkmark in headphones under the output tab. Tada. Otherwise it should just autowitch.

You can also just bind the two together. Since its just an outuput, who cares.