How to apply custom EDID within Manjaro Gnome X

Hey guys,
I’ve got a 5700xt chugging along just fine on a 70hz 1440p iiyama freesync monitor.
Im struck by the issues of memory clockspeed being stuck at 800mhz when im at 70hz, buts its idling @100mhz just fine on 60hz. Now the solution seems to be to increase blanking time (increase v.blank value in edid) and applying it either through xorg or a kernel mode setting in the default grub entry.
My issue is that it doesnt seem to be applied at all. Ive edited my EDID and ive even tried setting a custom modeline in the xorg.conf.d monitor config but nothing seems to stick. Im aware that ManjaroGnome is using a rootless xorg… might that be the issue?

Please help, i dont wanna be stuck with my card at 800mhz which prevents the fan from stopping and adding about 30w in idle.

my monitor.conf

Section "Monitor"
Identifier "DiplayPort-0"
Modeline "2560x1440_68.00"  357.00  2560 2760 3032 3504  1440 1443 1448 1500 -hsync +vsync
Option "PreferredMode" "2560x1440_68.00"
Option "ConnectedMonitor" "DisplayPort-0"
Option "CustomEDID" "DisplayPort-0:/etc/X11/xorg.conf.d/customedid.bin"
Option "IgnoreEDID" "false"
Option "UseEDID" "true"

it seems as if it simply ignores any of the xorg.conf files.

Does anyone have an idea how to get past this?

thanks in advance