How do I prevent Windows from changing the timezone

So Windows 10 keeps changing the timezone when I boot into it into UTC (this doesnt happen with every reboot, but it occurs often and now I've become terribly paranoid about windows showing the right time). I dont know if my mainboards clock is set to utc (I'll check later). All this happens even I have Windows set to automatically the set the time and find the timezone. Turning those things off and on again sets the right time (potentially only until the next reboot). Anyone know how to fix this permanently?

Sorry if it's dump question but...
Did you try to set timezone manually in "Date and Time" settings?

set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal to 1.

Pretty sure you have to make the key.

Alright I'll try that. What exactly does it do?

it basically tells windows that the time stored in the bios is UTC so it doesn't fuck up the time if your running a dual boot config between windows & linux.

So, I wasn't exactly sure what to create, but a quick google search told me its a DWORD (32-bit) (if thats not correct, please tell me)

Thanks for your help

If you do this make sure to disable Windows NTP.


If the above appears to have no effect, and a 64-bit variant of Windows is being used, using a QWORD value instead of a DWORD value may resolve the issue.