Return to

How do I edit monitor timings?


Hi, I’m starting to really enjoy how linux works. I’ve already completely moved to Antergos on my thinkpad but there is one huge issue that’s keeping me from doing the same on my main computer.
I CANNOT live without 75hz. It’s just too good for me in games and playing at 60hz makes me feel uncomfortable. My main monitor supports 75hz at specific monitor timings. I’ve tried to look around and follow a guide to overclocking refresh rates but that guide doesn’t show how i could edit the display resolution timings like on this picture :

on nvidia drivers back in 2015 there was a custom resolution option but I can’t seem to find it anymore on 418.56 drivers so I have to find some other way to edit it. Could anyone help me on this? I really want to switch to linux because of how ‘easy’ it is once you get used to it, but I simply can’t play games at 60hz.



So I presume that you are using x11 and not wayland since wayland does not play nice with Nvidia cards most of the time.

You want to use the xrander command to adjust display resolution and timings when using x11. There are also GUI frontends for for xrandr. See the Arch wiki page-

Also look at this tutorial on how to use xrander to overclock-

1 Like


fixed your image embed

1 Like


I have tried the method mentioned in your post, but sadly it does not work because I have no clue how to apply a pixel clock patch on linux. At first I thought it was because it wasn’t compatible with my monitor EDID and i worked around that but i kept getting badmatch error pop up. I’m just going to wait until one day nvidia actualy puts their custom driver tool back into the settings or i will just man up and buy a 120/144hz monitor. This is extremely dumb because back when i had a gtx 650 nvidia definitely had custom resolution settings on their ubuntu drivers

Edit: How exactly could I translate the number ’ cvt 1920 1080 75 ’ generate into the numbers on my screenshot in main post? If i could do this then maybe i could fix the issue