How do I add a screen resolution without setting it?

Hello,

I want to add a resolution but not set it, to avoid permanently screwing things up. This is for an HDMI out on my laptop. Currently it doesn't recognize a resolution that my HDMI splitter supports. Does anyone know how to do that?

I'm using Mint 17.3 Cinnamon.

A brief look around the web turned this up. It is older documentation but still looks relevant.
https://ubuntuforums.org/showthread.php?t=1112186
Also, I believe you may find some info here.
https://wiki.archlinux.org/index.php/Xrandr
Good luck

1 Like

Am I over looking anything??? Didn't work.......

Output:

adminz@adminz-System-Product-Name ~ $ gtf 3840 1080 60

# 3840x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 345.60 MHz
Modeline "3840x1080_60.00" 345.60 3840 4080 4496 5152 1080 1081 1084 1118 -HSync +Vsync

adminz@adminz-System-Product-Name ~ $ xrandr --newmode "3840x1080_60.00" 345.60 3840 4080 4496 5152 1080 1081 1084 1118 -HSync +Vsync
adminz@adminz-System-Product-Name ~ $ xrandr --addmode HDMI2 3840x1080_60
xrandr: cannot find mode "3840x1080_60"
adminz@adminz-System-Product-Name ~ $ xrandr --addmode HDMI2 3840x1080_60.00
adminz@adminz-System-Product-Name ~ $ xrandr --output HDMI2 --mode 3840x1080_60.00
xrandr: Configure crtc 1 failed
adminz@adminz-System-Product-Name ~ $ xrandr --output HDMI2 --mode 3840x1080_60.00
xrandr: Configure crtc 1 failed
adminz@adminz-System-Product-Name ~ $
adminz@adminz-System-Product-Name ~ $
adminz@adminz-System-Product-Name ~ $
adminz@adminz-System-Product-Name ~ $ xrandr | grep max
Screen 0: minimum 8 x 8, current 3286 x 1080, maximum 32767 x 32767
adminz@adminz-System-Product-Name ~ $

xrandr output:

adminz@adminz-System-Product-Name ~ $ xrandr
Screen 0: minimum 8 x 8, current 3286 x 1080, maximum 32767 x 32767
eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
1366x768 60.0*+ 40.0
1360x768 59.8 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected 1920x1080+1366+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080 60.0*+ 50.0 59.9
1920x1080i 60.1 50.0 60.0
1680x1050 59.9
1280x1024 75.0 60.0
1440x900 59.9
1280x960 60.0
1280x800 59.9
1152x864 75.0
1280x720 60.0 50.0 59.9
1440x576 50.0
1024x768 75.1 70.1 60.0
1440x480 60.0 59.9
832x624 74.6
800x600 72.2 75.0 60.3 56.2
720x576 50.0
720x576i 50.1
720x480 60.0 59.9
720x480i 60.1 60.1
640x480 75.0 66.7 60.0 59.9
720x400 70.1
3840x1080_60.00 60.0
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

@Mr_UNOwen,

1stly I recommend jumping on to the mint linux irc for live help.

but by the looks of this guide your syntax is wrong, well maybe not wrong but archlinux may use different implementation of xrandr to ubuntu/mint have a read of this bad boy.

https://wiki.ubuntu.com/X/Config/Resolution

I think it should be this

$ xrandr --output HDMI2 --mode 3840x1080 --rate 60

You can also edit xorg to statically set the display. It is also on the wiki above.

But my personal recommendation is KDE handle all of this natively, maybe have a look at it.

Let us know if you have success

Mac

So that ended up not working, here's the first attempt (just that line being the only thing done in the session):

adminz@adminz-System-Product-Name ~ $ xrandr --output HDMI2 --mode 3840x1080 --rate 60
xrandr: cannot find mode 3840x1080

On the second attempt I added the lines from before:

adminz@adminz-System-Product-Name ~ $ xrandr --newmode "3840x1080" 345.60 3840 4080 4496 5152 1080 1081 1084 1118 -HSync +Vsync
adminz@adminz-System-Product-Name ~ $ xrandr --addmode HDMI2 3840x1080
adminz@adminz-System-Product-Name ~ $ xrandr --output HDMI2 --mode 3840x1080 --rate 60
xrandr: Configure crtc 1 failed

This is for a display setup at my parents place. I'll try again in a month, flying back home for now...

Also...
After adding the mode and trying to set it via the Mint's default Display Settings menu, I get:

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark.gnome2drr_2derror_2dquark.Code2: could not set the configuration for CRTC 64