Return to Level1Techs.com

Home routers (3 chained) frequent dropouts - troubleshooting

Dear reader,

I am dealing with a home networking issue that is beyond my level of knowledge and capabilities. Which is quite low when it comes to networking, so please bear that in mind.

TL;DR
Network layout of three daisy chained routers has connection dropout issues on the main router (second in chain). Has worked for ±3 years without issues in current configuration, suddenly starts to cut out connection when it has to handle light to moderate bandwidth(?)/workload. Problem seems to be a conflict caused by one of the three routers. Cannot connect to router GUI during this issue. Rebooting this router (not resetting) solves the issue (takes ±5min to reconnect). Issue cannot be identified (on-board GUI diagnostics do not help much). Happens frequently, but without a pattern.

Setup and background
My home internet access is comprised of three routers on three levels of the house:

  • One Cisco EPC3928AD; ISP box and primarily acts as throughput to Asus; ground floor; DCHP enabled; IP XXX.XXX.XXX.1
  • One Asus RT-AC87U; installed for increased Wifi range; main connection device (nearly everything has been set to auto-connect to that); middle level; DHCP enabled; IP XXX.XXX.1.1
  • One Sitecom WLR-3100 V2 003 (X3 N300); mainly acts as LAN splitter for top level (2 PCs); GUI indicates “AP” mode but DHCP and Auto-IP are enabled; IP XXX.XXX.0.1

Please note that this (concrete walled and floored) house has no LAN infrastructure / cables running throughout it, hence the many routers.

All run in standard setup, meaning DHCP and all other stuff is on auto / enabled (the network layman out-of-the-box setting). Often called ‘Wireless router’ or something.
More info can be provided on request, for the sake of conciseness and not knowing what to provide, I will try to keep it short.

No new devices have been added, no changes have been made.
There are three permanent LAN devices (PCs), a few nearly-permanent WiFi devices (tablets, two phones) and a few intermittent WiFi devices (laptops, old PCs, my primary phone) ranging from few times a day to few times a year (old PC).

Speeds are (using Ookla):
WiFi of Cisco: ±69down / ±30up @ 17ms
Wired of Cisco: ±95down / ±31up @ 9ms
WiFi of Asus: ±298down / ±30up @ 18ms
Wired of Asus: ±95down / ±31up @ 10ms
WiFi of Sitecom: ±79down / ±30up @ 16ms
Wired of Sitecom: ±87down / ±up Unable - just disconnects and reboot is required @ 10ms

?why the high down with the Asus Wifi, but not the wired directly at Cisco? ISP package claims 300Mbit/s, which is only true for the Asus router via WiFi?

Problem
Network layout of three daisy chained routers has connection dropout issues on the main router (second in chain). Has worked for ±3 years without issues in current configuration, suddenly starts to cut out connection when it has to handle light to moderate bandwidth(?)/workload.

The first occurance is unknown, as I was on holiday. I noticed the day I returned. The router was not disconnected from power and internet. I cannot detect any auto-update of firmware or something during that time of absence.

Problem seems to be a conflict caused by one of the three routers. Cannot connect to router GUI during this issue. Rebooting this router (not resetting) solves the issue (takes ±5min to reconnect). Issue cannot be identified (mobile application GUI diagnostics do not help much). Happens frequently, but without a pattern. It can be instigated by simply starting to watch a YouTube video on one PC, while the other PC is already streaming some VOD (TV via internet for example). It could drop out at the beginning of that video (after 2 min or so) or midway (after 15min or so). The Asus router GUI cannot be reached when it is having this issue.

It seems the issue is the Asus router. I cannot, however, figure out why. Also, why this occurs only after ±3years.

Unrelated but annoying additional problem
The Sitecom router also just cuts out connection with light to medium bandwidth usage, but always with massive usage. This has always been an issue since about 5 years ago up till now (just drops out when doing wired down/up speed test), hence the reason why the Asus has been purchased to replace it on the middle level of the house. A simple unplug-plug reboot solves this. It does not restore connection on its own. The router GUI cannot be reached when it is having this issue. Not so much a problem when it just acts as top level switch, but it is when I have to replace the Asus router with the Sitecom and 5+ devices are connected to it as main internet access point.

What I’ve tried

  • Running GUI network diagnostics via Asus mobile application–> only points out that “there is no connection to the internet” (order is: your device>Asus router>modem>internet).
  • Removing Asus from chain, replaced by Sitecom (so no top level anymore, only 2 chained) → issue does not occur
  • Disabling DHCP on Asus → no internet access for connected devices / could not get to router GUI anymore(?)
  • Trying to learn how to set up daisy chained routers, but most guidelines did not help me trying to figure it out, as at most DHCP steps I could not figure out what settings to change (wording and options is different to most GUI of the guideline routers)
  • This includes changing the IP of the Asus from X.1 to X.2, but I was unable to connect to it after I did that, so I had to reset the Asus again.
  • Reserving the first X.1 till X.10 on the Cisco router
  • Reserving the first X.1 till X.10 on the Asus router
  • Factory reset (reset button) on Asus; Cisco; Sitecom (does not include firmware reset).
  • Updating the Asus firmware (current 3.0.0.4.382_50010-gb0c6a12) → gives error “The router cannot connect to ASUS server to check for the firmware update. After reconnecting to the Internet, go back to this page and click Check to check for the latest firmware updates.” While I am connected.
  • Running StarTrinity, but this only indicates the dropout time, not the cause of course.
  • Scanning the syslog file of the Asus router, but I cannot identify any obvious errors. One thing I did find was that it went from log entry date July 31st [current time] to Febuary 14th [01.00 time] to August 01st [current time] at some point, mutiple times. This was during one of the dropouts, but I cannot say with pinpoint accuracy as not all uptime log entries are included in this syslog.
  • There seem to be no IP conflicts, as every router has different IP adresses and IPs assigned to their devices. But this might not be true, as my knowledge on this is not that good.

Things I have not tried

  • Setting the Asus router to AP mode
  • Disabling any DHCP setting on the primary router (Cisco)
  • Disabling any DHCP setting on the tertiary router (Sitecom)
  • Much more I don’t know about

I suspect there is some conflict involving the IPs / DHCP settings, but I’m not sure. Then again, it also seems to be related to workload. Also, why would this have worked for ±years and now suddenly fail?

  1. Are there any obvious faults or setup issues?
  2. Are there any diagnostic steps or programs I can run in the background to log untill the issue occurs?
  3. Are there any other things I can try to solve?

This is not ideal in a work-from-home environment.

Thank you in advance.

Kind regards,
JB

How are Asus and Cisco connected to each other?
How are Sitecom and Asus connected?

Do you have any wifi channels set to auto?

Do you have access to the main isp provided router settings? Have you tried to set this router in IP Passthrough mode? It seems as though you are not connecting devices directly to this one?

Thank you both for your replies (I can’t multi-quote?). I will address your suggestions below.

@risk

  • Connection from ISP Sisco to Asus is wired cable, running from output #2 or something to wired input to Asus.
  • Connection from Asus to Sitecom is wired cable, running from output #3 or something to wired input to Sitecom.

On all routers, the WiFi channel settings are set to auto. I have seen people recommending to set that to 1, 6 or 11. But I have not tried that for the same reason as I am not very eager to change many other settings: it has always worked up untill now, for quite some time. I am, of course, not saying that this ‘could never be the cause’ and I am, of course, willing to try changing it, if that is what I think you are implying with that question. But I am hesitant in thinking it is.

I must mention that it seems that wired connections communicating between the Asus and the SiteCom seem to cause the interference, in most of the cases. Just now, when I wanted to check the replies, one PC was on (web browser open with non-demanding page) and one tablet was streaming video (both on Asus connection). I turned on a different PC, which is wired to Sitecom, started watching a video and the Asus one gave the red indicator light of ‘no internet’ in 2 minutes after doing so, i.e. the usual signal when this issue occurs. When I reboot the Asus it doesn’t always resolve it, sometimes I need to unplug-plug the power on the Sitecom as well, for the Asus to provide connection again. Exactly what I just had to do, which resolved the issue.

With my limited knowledge, and referring to the topics I have found so far, I am inclined to believe there is an IP issue between the Asus and Sitecom routers. I still find it quite odd that both routers then completely go full meltdown and become unresponsive to router GUI login attempts or WiFI connection attempts.

@StanSmith
I have access, and it seems without many or any restrictions (unlike other ISPs tend to do, where you are not allowed to change things). I cannot, however, find any option called IP Passthrough or something similar. I am usually not connected to this primary router, no. But sometimes the connection from the Asus does not provide good enough coverage, this is where the Cisco takes over (on the ground floor).

There is an option called ‘Connection Mode’ under Gateway Setup (WAN) under Management of the Administration tab. This should allow to the following options:

  • Bridge Mode
  • Router Mode
  • Connection Mode (DHCP Mode)

However, the dropdown menu associated with these Modes is locked. I cannot change anything. Perhaps I need to disable something somewhere else before I can, but the ‘Help’ page or other instructions do not indicate that.

FYI, I have now set the ‘DHCP Server’ on the Sitecom from Enabled to Disabled (under category LAN IP), but have kept ‘Auto IP Change’ on Enabled. I am interested in seeing if this could make a difference.

Again, thank you for your time and your replies. Looking forward to more information.

I don’t have either of the 3 routers you’re mentioning, it’s kind of hard for me to explain exactly how I’d set things up to minimize chance of issues (there’s some screenshots of how the UIs look online, that’s the best I can go off of).

I think what you need is to basically disable DHCP and not use the ASUS or Sitecom as routers (simplest would be to not use a WAN port on them, and also disable upnp on either to not confuse software running on various computers searching for a router locally).

If they’re not routing there’s less that can go wrong.

You can do it e.g. on Sitecom first and then on the Asus.


Auto channels can overlap (inefficient, 1,6,11 are far enough apart on 2.4 to allow for 20MHz WiFi to not overlap). In case of 5GHz , some channels are regulated DFS. There’s a process where an AP(or router) has to wait e.g. 5min or 15min for radar interference check before starting.

5GHz Channels like e.g. 36 or 149 are not DFS channels, but are more popular / bad in apartment buildings, ok for houses.


Is it possible any of your cables got frayed e.g. if you have them going under the doors or similar?

What you are experiencing sounds like hardware failure or an IP conflicts resulting in a spanking tree type scenario. Hence why the routers default reaction is to completely stop routing since it doesn’t know which route or IP to go to.

I would highly recommend to flatten this setup unless you learn more about setting up this type of setup. It’s not always as easy as plugging each router in to each other and put everything on auto.

With that said; in this type of setup you could get away with a more flat network (10.0.0.0/24) and have one DHCP service turned on on the main/default gateway route. Then set static IPs for all other routers (10.0.0.2,10.0.0.3,etc…). Then for the connections, I’d cable them together via their LAN port. Make sure all WiFi settings match as much as possible to enable roaming from each node. Turn off all other firewall and routing functions on all routers except the edge router to your ISP, or the one closest to the edge if you don’t want to use that ISP router.

That will get you 70% of the way there. The rest would come from your ability to set up and configure the three nodes. If you need something more complicated than this, you will need to give more information, possibly a network diagram, and do a little more research to each router and how to effectively set it up. With multiple routers on a chain like this you will be looking at double, even triple NAT. This might be part of your issues as well.

Thank you both for your additional information. My apologies for the late reply, but I was a bit occupied.

@risk
I had tried setting DHCP to off on the Sitecom first. At first I thought this had solved the issue, but see my story below. I had earlier attempted to turn off DHCP on the Asus router, but this resulted in a different issue of me not being able to connect to the GUI anymore for some reason.

The cables are not the issue, other than known problems (e.g. missing snap-fit plastic hinge thingy on one of them, causing it to not be as secure in the port as one would like). I have interchanged with different cables, without prevail.

@StanSmith
I was already suspecting this would be the case, but still had hope it would be something minor. Still weird that it has worked in this ‘auto’/all-routing setup since the beginning (±3y). I would have to do a bit of reading to understand your suggestions and how to implement them, but I do understand most of what you’re suggesting.

Anywho, I’ve had the following experience in the meantime. The Sitecom router started, as of two days ago, failing more and more often. I had noticed that disabling my VPN would sometimes reconnect the Sitecom again, which would then swiftly disconnect again after enabling the VPN after that previous reconnect. So I had to run without VPN in some instances. In the evening, it would not even reconnect anymore after the usual reboots in the chain. I could, normally, prevent the Asus one of tripping out if I was quick enough with the unplug-plug of the power on the Sitecom (within 30-45 sec). But this did not help anymore. The following day it also did not want to reconnect. Resetting the Sitecom router also did not work, it only reconnected for 1 minutes and then hit the dust again.

As of 28 hours ago, I am running a direct LAN between the Asus and the main PC on the top level. This would have been the cable that ran between the Sitecom and the Asus in the previous setup. With several unofficial stability tests (games, downloads, streaming, speedtests etc.) having been run during this period, I am (cautiously) able to say that this seems to be quite stable up till now. I have not experienced any dropouts.

I am, therefore, putting my bet on the Sitecom being the culprit of these issues. Be it misconfiguration or an over-time increasing hardware failure, of which the latter seems more likely given its previous fairly spotless track record, it seems this may have resolved it. This is not my final conclusion though, I will be monitoring and testing the stability in multiple different workload scenarios over the coming days / weeks.

For now, I thank you very much for your time and your input. I will not ignore your suggestions, but at the minute I am quite busy. Reading up on all the terminology and technicalities would require some investment in order to implement them correctly and optimally, which I would prefer to postpone for now.
In case anything tends to change for the worse, I will post it in this topic.

Kind regards,
JB

Just tossing a suggestion in, would it be possible for you to pick up a switch (instead of a router) to replace the sitecom, so whatever you had plugged into that can still be plugged into your network (but now with the Asus Router handling everything, such as DCHP, the sitecom was handling). As others have suggested, it would “flatten” the topology a little bit. And if need be pick up a dedicated Access Point and plug that into your new switch, to maintain any kind of necessary Wi-Fi coverage in that area ( you probably already have enough coverage from the other two routers though).

You can grab a Netgear or TP-Link 5 port switch for about $20.

You may want to try the discord server:

https://forum.level1techs.com/t/level1techs-discord-server/125955

There’s a #tech_support channel there where you can get someone to hold your hand while you set things up.


The process for Sitecom should go along these lines.

  1. Disconnect Sitecom from upstream Asus and all devices other than e.g. your laptop/admin device you’ll be using to change stuff (disable WiFi it needed)
  2. Reset Sitecom to factory and reboot it.
  3. Change Sitecom router IP to XXX.XXX.1.2/255.255.255.0 (into range of Asus) and if it doesn’t reboot itself, then you reboot it.
  4. Reconnect (disconnect and connect) laptop
  5. Change laptop to manual static XXX.XXX.1.250/255.255.255.0 (into range of Asus and Sitecom)
  6. Connect to Sitecom on XXX.XXX.1.2 disable DHCP and upnp
  7. Reboot Sitecom / make sure you still have access to it on XXX.XXX.1.2
  8. Connect the Asus LAN port with a Sitecom LAN port
  9. Re-enable getting IP over DHCP on your admin laptop
  10. Verify you’re getting an IP from Asus’ DHCP while connected to Sitecom LAN
  11. Re-enable/Configure wifi on Sitecom

Many modern os-es are screwy when they’re simultaneously connected to both Ethernet and wifi, and/or when you’re trying to use them on a network without internet access. Assuming you’re admin-ing this from a laptop you’ll probably have to work around some supposedly helpful features that get in your way in the middle of trying to setup your network stuff.

@anon35662433
Thank you for the suggestion. The Sitecom’s main purpose was to act as a switch. As I already had it laying around, it would save some cash in having to buy a new switch or AP at the time. I am looking into buying a ‘dumb’ switch, they can indeed be found between 20-30$ locally. Or maybe I’ll throw my PCE-AC68 in the PC that is currently unable to also be connected via a wired connection on that top level.
You’d be suprised how flaky the connection can be at some points for some devices, as some of them are not as good in receiving the signal (my new phone for example has much worse range than my older one).

@risk
Thank you for the explanation. It looks very familiar to the guidelines I had already found on chained router setups and tips on preventing IP or routing conflicts. I do not have Discord, but I will keep it in mind. Thank you, again.

Test the Asus router alone as my parents had one that one day just started dropping the internet connection (wifi and wired). I do not know how to fix it but hope this helps narrow it down.